summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-20 21:15:47 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-20 21:37:35 +0100
commit3b9b9bc5a3cace179a242e215fb857bb263c63a5 (patch)
tree1a901d24e0c6919e0a2439aa114db66aa862820f /sci-biology
parentapp-emulation/docker-proxy: Fix blocking version for docker (diff)
downloadgentoo-3b9b9bc5a3cace179a242e215fb857bb263c63a5.tar.gz
gentoo-3b9b9bc5a3cace179a242e215fb857bb263c63a5.tar.bz2
gentoo-3b9b9bc5a3cace179a242e215fb857bb263c63a5.zip
sci-biology/meme: Add $(DESTDIR) to install hooks
Gentoo-bug: 600316 Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/meme/files/meme-4.11.2_p2-fix-build-system.patch25
1 files changed, 24 insertions, 1 deletions
diff --git a/sci-biology/meme/files/meme-4.11.2_p2-fix-build-system.patch b/sci-biology/meme/files/meme-4.11.2_p2-fix-build-system.patch
index 0f3349c9583e..b548de5a39a5 100644
--- a/sci-biology/meme/files/meme-4.11.2_p2-fix-build-system.patch
+++ b/sci-biology/meme/files/meme-4.11.2_p2-fix-build-system.patch
@@ -7,7 +7,7 @@ Fix and modernise build system
--- a/configure.ac
+++ b/configure.ac
-@@ -76,61 +76,9 @@
+@@ -76,61 +76,10 @@
AM_CONDITIONAL(WANT_STRLCPY, test ["$have_strlcpy" = no])
# Check for compiler-specific settings
@@ -66,6 +66,7 @@ Fix and modernise build system
- LIBEXSLT_CFLAGS="-I\${top_srcdir}/src/libexslt"
- LIBXSLT_CFLAGS="-I\${top_srcdir}/src/"
-fi
++AC_PROG_MKDIR_P
+AC_SYS_LARGEFILE
+CFLAGS="-std=gnu89 -Wall -Wno-unused ${CFLAGS}"
+CPPFLAGS="-DUNIX -D__USE_FIXED_PROTOTYPES__ ${CPPFLAGS}"
@@ -272,6 +273,28 @@ Fix and modernise build system
memedoc_DATA = $(NORMAL_FILES)
endif
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -52,7 +52,7 @@
+ endif
+
+ dbdir:
+- mkdir -p $(MEME_DB)
++ $(MKDIR_P) $(DESTDIR)/$(MEME_DB)
+
+ all-local:
+ if WEBSITE
+@@ -64,8 +64,8 @@
+ endif
+
+ install-data-local:
+- mkdir -p $(MEME_LOGS)
+- chmod a+w $(MEME_LOGS)
++ $(MKDIR_P) $(DESTDIR)/$(MEME_LOGS)
++ chmod a+w $(DESTDIR)/$(MEME_LOGS)
+
+ distdir = $(PACKAGE)_$(VERSION)
+
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -22,8 +22,8 @@