summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 22:32:53 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 22:39:15 +0100
commit670461840c80b391afef997e0f0e94000894584d (patch)
treeb8b28f123714753dc74d71d69b6a4e8a6c39c551 /sci-biology
parentapp-doc/doxygen: Introduce := for clang dependency (diff)
downloadgentoo-670461840c80b391afef997e0f0e94000894584d.tar.gz
gentoo-670461840c80b391afef997e0f0e94000894584d.tar.bz2
gentoo-670461840c80b391afef997e0f0e94000894584d.zip
sci-biology/njplot: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/njplot/njplot-2.3-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/njplot/njplot-2.3-r2.ebuild b/sci-biology/njplot/njplot-2.3-r2.ebuild
new file mode 100644
index 000000000000..ac857840c1ab
--- /dev/null
+++ b/sci-biology/njplot/njplot-2.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A phylogenetic tree drawing program which supports tree rooting"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/njplot.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/njplot-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-biology/ncbi-tools[X,static-libs]
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s:njplot.help:${EPREFIX}/usr/share/doc/${PF}/njplot.help:" njplot-vib.c || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin newicktops newicktotxt njplot unrooted
+ doman *.1
+ dodoc README njplot.help
+}