summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-18 13:26:32 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-18 13:33:07 +0200
commit71e6df91447916064f790d4ec80e6a2ddd917ccf (patch)
tree622312bee0eb957e05a1b5444821932731132bc7 /sci-biology
parentsci-biology/lagan: Allow for compiling with GCC 6 (diff)
downloadgentoo-71e6df91447916064f790d4ec80e6a2ddd917ccf.tar.gz
gentoo-71e6df91447916064f790d4ec80e6a2ddd917ccf.tar.bz2
gentoo-71e6df91447916064f790d4ec80e6a2ddd917ccf.zip
sci-biology/lagan: Remove old ebuilds
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/lagan/lagan-2.0-r1.ebuild50
-rw-r--r--sci-biology/lagan/lagan-2.0-r2.ebuild55
2 files changed, 0 insertions, 105 deletions
diff --git a/sci-biology/lagan/lagan-2.0-r1.ebuild b/sci-biology/lagan/lagan-2.0-r1.ebuild
deleted file mode 100644
index 63b966e79ef0..000000000000
--- a/sci-biology/lagan/lagan-2.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils
-
-MY_P="lagan20"
-
-DESCRIPTION="LAGAN, Multi-LAGAN, Shuffle-LAGAN, Supermap: Whole-genome multiple alignment of genomic DNA"
-HOMEPAGE="http://lagan.stanford.edu/lagan_web/index.shtml"
-SRC_URI="http://lagan.stanford.edu/lagan_web/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -i "/use Getopt::Long;/ i use lib \"/usr/share/${PN}/lib\";" "${S}/supermap.pl" || die
- # NB: Testing with glibc-2.10 has uncovered a bug in src/utils/Sequence.h where libc getline is erroneously used instead of own getline
- sed -i 's/getline/my_getline/' "${S}"/src/{anchors.c,glocal/io.cpp} || die
- epatch "${FILESDIR}"/${P}-*.patch
-}
-
-src_install() {
- dobin lagan.pl slagan.pl mlagan
- rm lagan.pl slagan.pl utils/Utils.pm
- dodir /usr/share/${PN}/lib
- insinto /usr/share/${PN}/lib
- doins Utils.pm
- exeinto /usr/share/${PN}/utils
- doexe utils/*
- exeinto /usr/share/${PN}
- doexe *.pl anchors chaos glocal order prolagan
- insinto /usr/share/${PN}
- doins *.txt
- dosym /usr/share/${PN}/supermap.pl /usr/bin/supermap
- dosym /usr/bin/lagan.pl /usr/bin/lagan
- dosym /usr/bin/slagan.pl /usr/bin/slagan
- echo "LAGAN_DIR=\"/usr/share/${PN}\"" > ${S}/99${PN}
- doenvd "${S}/99${PN}"
- dodoc Readmes/README.*
-}
diff --git a/sci-biology/lagan/lagan-2.0-r2.ebuild b/sci-biology/lagan/lagan-2.0-r2.ebuild
deleted file mode 100644
index a37a3736de08..000000000000
--- a/sci-biology/lagan/lagan-2.0-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils multilib toolchain-funcs
-
-MY_P="lagan20"
-
-DESCRIPTION="LAGAN, Multi-LAGAN, Shuffle-LAGAN, Supermap: Whole-genome multiple alignment of genomic DNA"
-HOMEPAGE="http://lagan.stanford.edu/lagan_web/index.shtml"
-SRC_URI="http://lagan.stanford.edu/lagan_web/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -i "/use Getopt::Long;/ i use lib \"/usr/$(get_libdir)/${PN}/lib\";" "${S}/supermap.pl" || die
- # NB: Testing with glibc-2.10 has uncovered a bug in src/utils/Sequence.h where libc getline is erroneously used instead of own getline
- sed -i 's/getline/my_getline/' "${S}"/src/{anchors.c,glocal/io.cpp} || die
- epatch "${FILESDIR}"/${P}-*.patch
-}
-
-src_compile() {
- emake \
- CC=$(tc-getCC) \
- CXX=$(tc-getCXX) \
- CXXFLAGS="${CXXFLAGS}" \
- CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- newbin lagan.pl lagan || die
- newbin slagan.pl slagan || die
- dobin mlagan || die
- rm lagan.pl slagan.pl utils/Utils.pm
-
- insinto /usr/$(get_libdir)/${PN}/lib
- doins Utils.pm || die
- exeinto /usr/$(get_libdir)/${PN}/utils
- doexe utils/* || die
- exeinto /usr/$(get_libdir)/${PN}
- doexe *.pl anchors chaos glocal order prolagan || die
- insinto /usr/$(get_libdir)/${PN}
- doins *.txt || die
- dosym /usr/$(get_libdir)/${PN}/supermap.pl /usr/bin/supermap
- echo "LAGAN_DIR=\"/usr/$(get_libdir)/${PN}\"" > ${S}/99${PN}
- doenvd "${S}/99${PN}" || die
- dodoc Readmes/README.* || die
-}