summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-08-13 12:33:50 +0200
committerDavid Seifert <soap@gentoo.org>2016-08-13 12:34:09 +0200
commitaee8fa1dbbe56f8f592e3d4dfc4bc6832126a45a (patch)
treedde6292b76bd11ee0fdfd962a3a0f0bc1ad5c83a /sci-biology
parentdev-python/rarfile: add python:3.5 support #590352 (diff)
downloadgentoo-aee8fa1dbbe56f8f592e3d4dfc4bc6832126a45a.tar.gz
gentoo-aee8fa1dbbe56f8f592e3d4dfc4bc6832126a45a.tar.bz2
gentoo-aee8fa1dbbe56f8f592e3d4dfc4bc6832126a45a.zip
sci-biology/allpathslg: Unconditionally require OpenMP support
Gentoo-bug: 591166 * The configure script of sci-biology/allpathslg allows for specifying --enable/--disable-openmp, without it actually being optional. Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/allpathslg/allpathslg-52488-r2.ebuild (renamed from sci-biology/allpathslg/allpathslg-52488-r1.ebuild)27
1 files changed, 17 insertions, 10 deletions
diff --git a/sci-biology/allpathslg/allpathslg-52488-r1.ebuild b/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
index 268d7594f9cc..4164bce9d896 100644
--- a/sci-biology/allpathslg/allpathslg-52488-r1.ebuild
+++ b/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit autotools flag-o-matic
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
# see also http://www.broadinstitute.org/software/allpaths-lg/blog/?page_id=12
@@ -14,14 +14,13 @@ SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="openmp"
RDEPEND="
!sci-biology/allpaths
!sci-biology/vaal"
DEPEND="
${RDEPEND}
- dev-libs/boost"
+ dev-libs/boost:="
PATCHES=(
"${FILESDIR}/${P}_fix-buildsystem.patch"
@@ -33,8 +32,21 @@ pkg_pretend() {
# seems pre gcc-4.7 users must stay with:
# ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/2013/2013-01/allpathslg-44837.tar.gz
if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(tc-getCC) == *gcc* ]] && [[ $(gcc-version) < 4.7 ]] && \
- die "You need to use gcc >4.7"
+ tc-is-gcc && [[ $(gcc-version) < 4.7 ]] && \
+ die "You need to use gcc >4.7"
+ fi
+}
+
+pkg_setup() {
+ if ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+
+ if tc-is-clang; then
+ ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
+ ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
+ fi
+
+ die "need openmp capable compiler"
fi
}
@@ -43,8 +55,3 @@ src_prepare() {
eautoreconf
}
-
-src_configure() {
- econf \
- $(use_enable openmp)
-}