summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-08 19:46:32 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-08 19:47:12 +0100
commitf21f66667be7601f9721f0d67bb1cec3478fe8bb (patch)
tree873f45502a85494e539d2eb4f06d00ea8d2ea63f /sci-biology
parentremove openstack-guest-agents-unix and xe-guest-utilities from package.mask (diff)
downloadgentoo-f21f66667be7601f9721f0d67bb1cec3478fe8bb.tar.gz
gentoo-f21f66667be7601f9721f0d67bb1cec3478fe8bb.tar.bz2
gentoo-f21f66667be7601f9721f0d67bb1cec3478fe8bb.zip
sci-biology/biosql: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biosql/biosql-1.0.1-r1.ebuild (renamed from sci-biology/biosql/biosql-1.0.1.ebuild)33
1 files changed, 22 insertions, 11 deletions
diff --git a/sci-biology/biosql/biosql-1.0.1.ebuild b/sci-biology/biosql/biosql-1.0.1-r1.ebuild
index 950e6d347f84..6508d6a3a2e8 100644
--- a/sci-biology/biosql/biosql-1.0.1.ebuild
+++ b/sci-biology/biosql/biosql-1.0.1-r1.ebuild
@@ -1,32 +1,43 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
DESCRIPTION="A generic bioinformatics relational database model"
HOMEPAGE="http://www.biosql.org/"
SRC_URI="http://biosql.org/DIST/${P}.tar.bz2"
LICENSE="LGPL-3"
SLOT="0"
-IUSE="mysql postgres"
KEYWORDS="amd64 x86"
+IUSE="mysql postgres"
# WARNING: bioperl-db is claimed to be incompatible with >=postgresql-8.3 (see INSTALL)
-DEPEND="mysql? ( dev-perl/DBD-mysql )
+DEPEND="
+ mysql? ( dev-perl/DBD-mysql )
postgres? ( dev-perl/DBD-Pg )"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl"
src_install() {
insinto /usr/share/${PN}
- doins -r sql scripts/* || die
- insinto /usr/share/doc/${P}
- doins -r doc/*
- dodoc Changes INSTALL README Release.txt
+ doins -r sql scripts/.
+
+ dodoc Changes README Release.txt doc/*.pdf
+
+ docinto biopython
+ dodoc doc/{README,schema-overview.txt,biopython/{cor6_6.gb,*.pdf}}
+ docompress -x /usr/share/doc/${PF}/biopython
+
+ docinto html
+ dodoc doc/{biopython/,}*.htm*
}
pkg_postinst() {
- echo
+ elog
elog "Please read the BioSQL schema installation instructions in"
- elog "/usr/share/doc/${P} to begin using the schema."
- echo
+ elog "${EROOT%/}/usr/share/doc/${PF} to begin using the schema."
+ elog
}