summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-09-16 05:25:33 +0200
committerJeroen Roovers <jer@gentoo.org>2015-09-16 05:26:33 +0200
commit7d8bfc3874266ea9f4cae31c0ffa7a501b89c081 (patch)
tree4f4a4a25a44538540281873fb91335c13e4623f8 /sci-calculators/units
parentdev-vcs/blogc-git-receiver: version bump, fixed -9999 (diff)
downloadgentoo-7d8bfc3874266ea9f4cae31c0ffa7a501b89c081.tar.gz
gentoo-7d8bfc3874266ea9f4cae31c0ffa7a501b89c081.tar.bz2
gentoo-7d8bfc3874266ea9f4cae31c0ffa7a501b89c081.zip
sci-calculators/units: Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-calculators/units')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.11d.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index 4acd6bebf414..e5365a61bf26 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1,2 +1,3 @@
DIST units-2.11.tar.gz 861772 SHA256 53b6daf2a03d9a060449944b0a6c1aca0d18a84d1d9a93098e4a8920181f5abe SHA512 83e062a0daf9541454cdcaa4efe03bf9f03afdcfdbe2013d5e913a53e1b5e37ef846a3129185898ad2d25e3ea632533f8eb8d89681c855b19a3998aca6e733ce WHIRLPOOL 4c405e0a81af2b02d05156225c26573631ddb02d323d160b0850fcfda52b4a84a36f3ddbfdc732aa8a9dc06c8fc59a41141f985d6025ea6cb18b87749b78d500
DIST units-2.11a.tar.gz 865120 SHA256 cdc1ef5adf0701f9bf0f9e3c890cd832554e5bf3f078dab852e5a6783e525b8b SHA512 d942194b73a4d920d711bdcf07481aefff8fc1403f47ca73c1c0fd9837cb7c385a45f326d9537ba1aa77283c4f812be346a1b5ac15ca1e508c268857cc9d78db WHIRLPOOL 72efc473f9105796bdbdc92e2e355a0a2c8ede0ae5febbc017a112b6524e6ad9081a581cc22666ed4e7e74a87bf1b8d45e3a262df53358cbe32107edbe4b6230
+DIST units-2.11d.tar.gz 868580 SHA256 f1ba31658de19fa4ab3ecf791a08c590dc4f6dd5903c771bb9d678ba68ac785b SHA512 6e0dac8ae8830d0ab914e6e367f9473ac8c860cde9d189d05a8ade047037d21884a66e07733e8decc4d95325dcfb5a7110e4552b4b47c72b746cdc248354c1e5 WHIRLPOOL a54a33f50a0976d180e889485600de5354c94302dbe4b83aaff732efe9d473a07295d447b6d1df9fef766c35cb9571c947c4f12a23f8c21f8665ddb365078914
diff --git a/sci-calculators/units/units-2.11d.ebuild b/sci-calculators/units/units-2.11d.ebuild
new file mode 100644
index 000000000000..b08c0855a475
--- /dev/null
+++ b/sci-calculators/units/units-2.11d.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+inherit eutils python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+
+DEPEND="
+ >=sys-libs/readline-4.1-r2
+ units_cur? (
+ dev-lang/python-exec:2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ units_cur? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+"
+
+units_cur_prepare() {
+ local UNITS_PYTHON_MAJOR
+ UNITS_PYTHON_MAJOR=$(
+ UNITS_PYTHON_MAJOR=${EPYTHON/.*}
+ shopt -s extglob
+ echo ${UNITS_PYTHON_MAJOR/*([[:alpha:]])}
+ )
+ sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" units_cur${UNITS_PYTHON_MAJOR} > units_cur-${EPYTHON}
+}
+
+src_prepare() {
+ use units_cur && python_foreach_impl units_cur_prepare
+}
+
+src_compile() {
+ emake HAVE_PYTHON=no
+}
+
+units_cur_install() {
+ python_newexe units_cur-${EPYTHON} units_cur
+}
+
+src_install() {
+ emake DESTDIR="${D}" HAVE_PYTHON=no install
+
+ dodoc ChangeLog NEWS README
+
+ use units_cur && python_foreach_impl units_cur_install
+}