summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-10-04 14:07:17 +0200
committerJeroen Roovers <jer@gentoo.org>2020-10-04 14:07:42 +0200
commitd1d3eef2eccc25444da4f05b1cae90dccf402b80 (patch)
treec0cd001f85bc65b433d62d876f12d0fc98704d15 /sci-calculators/units
parentx11-misc/xlockmore: Old (diff)
downloadgentoo-d1d3eef2eccc25444da4f05b1cae90dccf402b80.tar.gz
gentoo-d1d3eef2eccc25444da4f05b1cae90dccf402b80.tar.bz2
gentoo-d1d3eef2eccc25444da4f05b1cae90dccf402b80.zip
sci-calculators/units: Fix unwanted double hyphen in USE flag name
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Fixes: 249a76e82566d2597d8a5f5c1445f49bce6e54e4 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sci-calculators/units')
-rw-r--r--sci-calculators/units/metadata.xml2
-rw-r--r--sci-calculators/units/units-2.16-r1.ebuild10
-rw-r--r--sci-calculators/units/units-2.18.ebuild10
-rw-r--r--sci-calculators/units/units-2.19-r1.ebuild10
-rw-r--r--sci-calculators/units/units-2.20.ebuild8
5 files changed, 20 insertions, 20 deletions
diff --git a/sci-calculators/units/metadata.xml b/sci-calculators/units/metadata.xml
index f0a40a93849f..b411ce916025 100644
--- a/sci-calculators/units/metadata.xml
+++ b/sci-calculators/units/metadata.xml
@@ -6,6 +6,6 @@
<name>Jeroen Roovers</name>
</maintainer>
<use>
-<flag name="units--cur">Install the units_cur python script that updates currencies</flag>
+<flag name="units-cur">Install the units_cur python script that updates currencies</flag>
</use>
</pkgmetadata>
diff --git a/sci-calculators/units/units-2.16-r1.ebuild b/sci-calculators/units/units-2.16-r1.ebuild
index b6e116cc86eb..6bea3362ca40 100644
--- a/sci-calculators/units/units-2.16-r1.ebuild
+++ b/sci-calculators/units/units-2.16-r1.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units--cur"
-REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
- units--cur? (
+ units-cur? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/future[${PYTHON_MULTI_USEDEP}]
@@ -30,7 +30,7 @@ DEPEND="
"
pkg_setup() {
- use units--cur && python-single-r1_pkg_setup
+ use units-cur && python-single-r1_pkg_setup
}
src_configure() {
@@ -49,7 +49,7 @@ src_install() {
# we're intentionally delaying this since 'make install' would
# get confused if we shove 'units_cur' there, and there is no real
# need to add more complexity for it
- if use units--cur; then
+ if use units-cur; then
sed \
-e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
-e 's|^#!|&/usr/bin/python|g' \
diff --git a/sci-calculators/units/units-2.18.ebuild b/sci-calculators/units/units-2.18.ebuild
index b110fbdd91bf..8f8ba8b7c387 100644
--- a/sci-calculators/units/units-2.18.ebuild
+++ b/sci-calculators/units/units-2.18.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units--cur"
-REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
- units--cur? (
+ units-cur? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/future[${PYTHON_MULTI_USEDEP}]
@@ -33,7 +33,7 @@ PATCHES=(
)
pkg_setup() {
- use units--cur && python-single-r1_pkg_setup
+ use units-cur && python-single-r1_pkg_setup
}
src_configure() {
@@ -54,7 +54,7 @@ src_install() {
# we're intentionally delaying this since 'make install' would
# get confused if we shove 'units_cur' there, and there is no real
# need to add more complexity for it
- if use units--cur; then
+ if use units-cur; then
sed \
-e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
-e 's|^#!|&/usr/bin/python|g' \
diff --git a/sci-calculators/units/units-2.19-r1.ebuild b/sci-calculators/units/units-2.19-r1.ebuild
index 08fba4f5f9b1..b68b04a87f90 100644
--- a/sci-calculators/units/units-2.19-r1.ebuild
+++ b/sci-calculators/units/units-2.19-r1.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units--cur"
-REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
- units--cur? (
+ units-cur? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/future[${PYTHON_MULTI_USEDEP}]
@@ -36,7 +36,7 @@ DOCS=(
)
pkg_setup() {
- use units--cur && python-single-r1_pkg_setup
+ use units-cur && python-single-r1_pkg_setup
}
src_configure() {
@@ -55,7 +55,7 @@ src_install() {
# we're intentionally delaying this since 'make install' would
# get confused if we shove 'units_cur' there, and there is no real
# need to add more complexity for it
- if use units--cur; then
+ if use units-cur; then
sed \
-e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
-e 's|^#!|&/usr/bin/python|g' \
diff --git a/sci-calculators/units/units-2.20.ebuild b/sci-calculators/units/units-2.20.ebuild
index a601e8f3fc01..40e4195d89a7 100644
--- a/sci-calculators/units/units-2.20.ebuild
+++ b/sci-calculators/units/units-2.20.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="+units--cur"
-REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
- units--cur? (
+ units-cur? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/future[${PYTHON_USEDEP}]
@@ -50,7 +50,7 @@ src_compile() {
src_install() {
default
- if use units--cur; then
+ if use units-cur; then
sed \
-e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
-e 's|^#!|&/usr/bin/python|g' \