summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 07:19:56 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:54 +0300
commitef7a79a4c856d9737cd85bcae0b934a58a5ea115 (patch)
treeca663768b4ff4bf4839688cc89533cdd23166723 /sci-calculators
parentnet-misc/x11-ssh-askpass: fix build with -native-symlinks (diff)
downloadgentoo-ef7a79a4c856d9737cd85bcae0b934a58a5ea115.tar.gz
gentoo-ef7a79a4c856d9737cd85bcae0b934a58a5ea115.tar.bz2
gentoo-ef7a79a4c856d9737cd85bcae0b934a58a5ea115.zip
sci-calculators/hexcalc: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/725330 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
index e76181650805..c9740ad088e8 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,15 +16,19 @@ IUSE=""
RDEPEND="x11-libs/libXaw"
DEPEND="${RDEPEND}
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
app-text/rman"
S=${WORKDIR}/${PN}
PATCHES=( "${FILESDIR}"/${PN}-{keypad,order}.diff )
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+}
+
src_compile() {
- xmkmf || die
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \