summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pdbcat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pdbcat')
-rw-r--r--sci-chemistry/pdbcat/Manifest1
-rw-r--r--sci-chemistry/pdbcat/files/CMakeLists.txt11
-rw-r--r--sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch17
-rw-r--r--sci-chemistry/pdbcat/metadata.xml24
-rw-r--r--sci-chemistry/pdbcat/pdbcat-1.3.ebuild24
5 files changed, 77 insertions, 0 deletions
diff --git a/sci-chemistry/pdbcat/Manifest b/sci-chemistry/pdbcat/Manifest
new file mode 100644
index 000000000000..80690fe7ac00
--- /dev/null
+++ b/sci-chemistry/pdbcat/Manifest
@@ -0,0 +1 @@
+DIST pdbcat-1.3.tar.gz 12750 SHA256 a9c554c00b34e5131ca1be61aad9332ab26eca5a905b716c47f657521368babc SHA512 369ac0c4c1d8396eaa0450feb9852d2d75ebd9862a2e403ccd42a2801e924f99c28c5d71c0b66feb4588076a8948b503823d2c75420128dd04d020253f821f4c WHIRLPOOL ba6599d06814929bf23c83bb6df7084592fcc23603a8e3116e2661df3c9d97b335c627d09249be6c862466b2d83a0100d94b366df171e1c45ec6221a22b2ca78
diff --git a/sci-chemistry/pdbcat/files/CMakeLists.txt b/sci-chemistry/pdbcat/files/CMakeLists.txt
new file mode 100644
index 000000000000..7a6f348f5929
--- /dev/null
+++ b/sci-chemistry/pdbcat/files/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required (VERSION 2.6)
+project (pdbcat)
+add_executable(pdbcat
+ Common.C
+ Common.h
+ pdbcat.C
+ PDBData.C
+ PDBData.h)
+
+install (TARGETS pdbcat DESTINATION bin)
+
diff --git a/sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch b/sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch
new file mode 100644
index 000000000000..b45c36bd8a8d
--- /dev/null
+++ b/sci-chemistry/pdbcat/files/pdbcat-1.3-gcc.patch
@@ -0,0 +1,17 @@
+ pdbcat.C | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/pdbcat.C b/pdbcat.C
+index 0786d9b..387edf9 100644
+--- a/pdbcat.C
++++ b/pdbcat.C
+@@ -17,7 +17,8 @@
+ #include <stdlib.h> // for exit
+ #include <stdio.h> // for feof() and other file manip stuff
+ #include <string.h> // for strcasecmp
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+ #include "Common.h"
+ #include "PDBData.h"
+
diff --git a/sci-chemistry/pdbcat/metadata.xml b/sci-chemistry/pdbcat/metadata.xml
new file mode 100644
index 000000000000..54c920d084c3
--- /dev/null
+++ b/sci-chemistry/pdbcat/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+The Brookhaven Protein Data Bank stores atomic coordinate information
+for protein structures in a column based format. This is designed to
+be read easily read by FORTRAN programs. Indeed, if you get the
+format description (from anonymous ftp to ftp.pdb.bnl.gov, the file
+/pub/format.desc.ps) they show the single input line needed to read
+each record type.
+However, I am a C/C++ programmer in the Unix environment. It is a
+easier for me to deal with field based input than column based ones.
+If the fields are white space delimited I can easily use awk and perl
+to manipulate the coordinate information. So I needed some way to
+convert the ATOM and HETATM records of PDB files from the standard
+column based format to a field based one and back again. It needed
+to denote missing fields if they exist.
+That converter is `pdbcat'.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/pdbcat/pdbcat-1.3.ebuild b/sci-chemistry/pdbcat/pdbcat-1.3.ebuild
new file mode 100644
index 000000000000..f0d0b263a446
--- /dev/null
+++ b/sci-chemistry/pdbcat/pdbcat-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Manipulate and process PDB files using commonly available tools such as Perl, awk, etc"
+HOMEPAGE="http://www.ks.uiuc.edu/Development/MDTools/pdbcat/"
+SRC_URI="http://www.ks.uiuc.edu/Development/MDTools/${PN}/files/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-gcc.patch )
+DOCS=( README )
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+ cmake-utils_src_prepare
+}