summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-28 16:48:17 +0100
committerJustin Lecher <jlec@gentoo.org>2016-03-29 22:16:24 +0200
commit4e781fbeb750f7d8ad70319f0f5386708aacbdb3 (patch)
tree82304725d5e4a4bb7a286f9a0384631fc9f8a28d /sci-chemistry
parentdev-python: break lines at < 80 chars (diff)
downloadgentoo-4e781fbeb750f7d8ad70319f0f5386708aacbdb3.tar.gz
gentoo-4e781fbeb750f7d8ad70319f0f5386708aacbdb3.tar.bz2
gentoo-4e781fbeb750f7d8ad70319f0f5386708aacbdb3.zip
sci-chemistry/chemical-mime-data: Add missing png&svg support for imagemagick during build
* Bump to EAPI=6 * Use xdg.eclass instead of fdo-mime.eclass * Optional usage of gnome-base/librsvg instead of media-gfx/imagemagick Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=575904 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild
new file mode 100644
index 000000000000..c486f6864198
--- /dev/null
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools xdg
+
+DESCRIPTION="A collection of data files to add support for chemical MIME types"
+HOMEPAGE="http://chemical-mime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/-data/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ gnome-base/gnome-mime-data
+ x11-misc/shared-mime-info"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/desktop-file-utils
+ dev-libs/libxslt
+ || (
+ media-gfx/imagemagick[xml,png,svg]
+ gnome-base/librsvg
+ )
+ media-gfx/inkscape
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-turbomole.patch
+ "${FILESDIR}"/${P}-pigz.patch
+ "${FILESDIR}"/${P}-namespace-svg.patch
+ )
+
+src_prepare() {
+ xdg_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-update-database
+ --htmldir=/usr/share/doc/${PF}/html
+ )
+ econf ${myeconfargs[@]}
+}