summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-04 20:24:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-04 20:28:09 +0100
commitfddaa01871af3e465b9bc4833a0ad68a2b91ffbb (patch)
tree463cd1662560204ac57be152f9d5c6e60cd0bcba /sci-chemistry
parentsys-apps/portage: Bump version (diff)
downloadgentoo-fddaa01871af3e465b9bc4833a0ad68a2b91ffbb.tar.gz
gentoo-fddaa01871af3e465b9bc4833a0ad68a2b91ffbb.tar.bz2
gentoo-fddaa01871af3e465b9bc4833a0ad68a2b91ffbb.zip
sci-chemistry/openbabel: Drop old
obsoletes Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=449852 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=553104 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.2.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.3.2.ebuild b/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
deleted file mode 100644
index b35374814b48..000000000000
--- a/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-WX_GTK_VER="2.8"
-
-inherit cmake-utils eutils wxwidgets
-
-DESCRIPTION="Interconverts file formats used in molecular modeling"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc openmp test wxwidgets"
-
-RDEPEND="
- dev-cpp/eigen:3
- dev-libs/libxml2:2
- sci-libs/inchi
- sys-libs/zlib
- wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.4.8
- doc? ( app-doc/doxygen )"
-
-DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
-
-PATCHES=( "${FILESDIR}"/${P}-test_lib_path.patch )
-
-pkg_setup() {
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
-}
-
-src_configure() {
- local mycmakeargs=""
- mycmakeargs="${mycmakeargs}
- -DOPENBABEL_USE_SYSTEM_INCHI=ON
- $(cmake-utils_use_enable openmp OPENMP)
- $(cmake-utils_use wxwidgets BUILD_GUI)"
-
- cmake-utils_src_configure
-}
-
-src_install() {
- dohtml doc/{*.html,*.png}
- if use doc ; then
- insinto /usr/share/doc/${PF}/API/html
- doins doc/API/html/*
- fi
-
- cmake-utils_src_install
-}
-
-src_test() {
- local mycmakeargs=""
- mycmakeargs="${mycmakeargs}
- -DOPENBABEL_USE_SYSTEM_INCHI=ON
- -DPYTHON_EXECUTABLE=false
- $(cmake-utils_use_enable openmp OPENMP)
- $(cmake-utils_use wxwidgets BUILD_GUI)
- $(cmake-utils_use_enable test TESTS)"
-
- cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test -E py
-}
-
-pkg_postinst() {
- optfeature "perl support" sci-chemistry/openbabel-perl
- optfeature "python support" sci-chemistry/openbabel-python
-}