summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/electronics-menu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/electronics-menu')
-rw-r--r--sci-electronics/electronics-menu/Manifest1
-rw-r--r--sci-electronics/electronics-menu/electronics-menu-1.0-r1.ebuild36
-rw-r--r--sci-electronics/electronics-menu/electronics-menu-1.0.ebuild36
-rw-r--r--sci-electronics/electronics-menu/metadata.xml10
4 files changed, 83 insertions, 0 deletions
diff --git a/sci-electronics/electronics-menu/Manifest b/sci-electronics/electronics-menu/Manifest
new file mode 100644
index 000000000000..cafff23ece95
--- /dev/null
+++ b/sci-electronics/electronics-menu/Manifest
@@ -0,0 +1 @@
+DIST electronics-menu-1.0.tar.gz 12284 SHA256 b2ca878cebbafc0eda7ef1b88aff9ac83a8e1b92781b30610dd58a5b8b35b320 SHA512 c4619d6dfd0641da772a7026af50b0ba1ededee6a5be84ede1c058671764f8c9a7d55e44a018f6bd42bbef0a29d513df5e9056a9a345999a2493fa62d2300b0a WHIRLPOOL 07bb5d1929edba9e6f0b5290f3297e439a4a01e9d953bb6f1cde89de06c6cf495cf9b38b1fda1b572c27fa03581d472d5cb83f0408857a7606dd18c26a7a9e5b
diff --git a/sci-electronics/electronics-menu/electronics-menu-1.0-r1.ebuild b/sci-electronics/electronics-menu/electronics-menu-1.0-r1.ebuild
new file mode 100644
index 000000000000..f34b53a54c3b
--- /dev/null
+++ b/sci-electronics/electronics-menu/electronics-menu-1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnome2-utils
+
+DESCRIPTION="Creates an \"Electronics\" desktop menu"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://geda.seul.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/electronics-menu/electronics-menu-1.0.ebuild b/sci-electronics/electronics-menu/electronics-menu-1.0.ebuild
new file mode 100644
index 000000000000..3e1da3ca7ce0
--- /dev/null
+++ b/sci-electronics/electronics-menu/electronics-menu-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit gnome2-utils
+
+DESCRIPTION="Creates an \"Electronics\" desktop menu"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://geda.seul.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${ED}" install || die "emake install failed"
+ dodoc README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/electronics-menu/metadata.xml b/sci-electronics/electronics-menu/metadata.xml
new file mode 100644
index 000000000000..6c07ad627655
--- /dev/null
+++ b/sci-electronics/electronics-menu/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ Create a dedicated "Electronics" entry in the top-menu of your XDG-compliant
+ Desktop Environment (Gnome, KDE, etc...), so that you electronics
+ applications don't get stuck in "Education" anymore.
+ </longdescription>
+</pkgmetadata>