summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-20 17:39:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-20 17:53:58 +0100
commit957eca3b3db92500ee7344dce15c919dbcfc80c0 (patch)
tree432b145e16a7bc21c1b6abde2be11cd25af8925f /sci-electronics/gazebo/gazebo-8.2.0.ebuild
parentdev-ros/robot_localization: bump to 2.4.1 (diff)
downloadgentoo-957eca3b3db92500ee7344dce15c919dbcfc80c0.tar.gz
gentoo-957eca3b3db92500ee7344dce15c919dbcfc80c0.tar.bz2
gentoo-957eca3b3db92500ee7344dce15c919dbcfc80c0.zip
sci-electronics/gazebo: bump to 8.2.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-electronics/gazebo/gazebo-8.2.0.ebuild')
-rw-r--r--sci-electronics/gazebo/gazebo-8.2.0.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/gazebo-8.2.0.ebuild b/sci-electronics/gazebo/gazebo-8.2.0.ebuild
new file mode 100644
index 000000000000..72cc1dca1b33
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-8.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/8"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ dev-libs/tinyxml2:=
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4[freeimage]
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ libav? ( >=media-video/libav-9:0= )
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-5.0:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads]
+ sci-libs/gdal
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:=
+ >=sci-libs/ignition-math-2.3:3=
+ net-libs/ignition-transport:3=
+ x11-libs/qwt:6=[qt5]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ app-text/ronn
+ app-arch/gzip
+ virtual/pkgconfig
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/qwt.patch" )
+
+src_configure() {
+ # doesnt build without it
+ append-cxxflags "-std=c++11"
+ # doesnt build with as-needed either
+ append-ldflags "-Wl,--no-as-needed"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake-utils_src_configure
+}