summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-06-29 19:11:38 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2021-06-29 19:11:38 +0200
commitc13c78180b2338d95ffbbf776ee4f3c3702170d5 (patch)
treefe1b778449638f6886eb1c8f896c8f3bb42f3b59 /sci-electronics/puff/puff-20100127-r1.ebuild
parentsys-apps/plocate: drop 1.1.7-r1 (diff)
downloadgentoo-c13c78180b2338d95ffbbf776ee4f3c3702170d5.tar.gz
gentoo-c13c78180b2338d95ffbbf776ee4f3c3702170d5.tar.bz2
gentoo-c13c78180b2338d95ffbbf776ee4f3c3702170d5.zip
sci-electronics/puff: Adapt to changes in Free Pascal compiler
Closes: https://bugs.gentoo.org/798264 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-electronics/puff/puff-20100127-r1.ebuild')
-rw-r--r--sci-electronics/puff/puff-20100127-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-electronics/puff/puff-20100127-r1.ebuild b/sci-electronics/puff/puff-20100127-r1.ebuild
index 0c27ca623e46..c13ddfb11313 100644
--- a/sci-electronics/puff/puff-20100127-r1.ebuild
+++ b/sci-electronics/puff/puff-20100127-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,9 +20,10 @@ DEPEND="${RDEPEND}
src_prepare() {
default
# fix lib path for X11 and dont ignore LDFLAGS
- sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
+ sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
-e 's/CFLAGS/#CFLAGS/' \
- -e 's/link.res pu/link.res $(LDFLAGS) pu/' Makefile || die
+ -e 's/link.res/.res/g' \
+ -e 's/.res pu/.res $(LDFLAGS) pu/' Makefile || die
}
src_compile() {