summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-06-30 20:23:24 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2021-06-30 20:23:24 +0200
commit6ae6627d53481ea1859fd1f071949f062e441a0a (patch)
tree43fc2bde96f846bd6f3373e8891f9956b839c0be /sci-electronics/puff
parentsys-kernel/gentoo-sources: Linux patch 5.12.14 (diff)
downloadgentoo-6ae6627d53481ea1859fd1f071949f062e441a0a.tar.gz
gentoo-6ae6627d53481ea1859fd1f071949f062e441a0a.tar.bz2
gentoo-6ae6627d53481ea1859fd1f071949f062e441a0a.zip
sci-electronics/puff: Do not call gcc directly
Closes: https://bugs.gentoo.org/799269 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-electronics/puff')
-rw-r--r--sci-electronics/puff/puff-20100127-r1.ebuild5
-rw-r--r--sci-electronics/puff/puff-20181104.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sci-electronics/puff/puff-20100127-r1.ebuild b/sci-electronics/puff/puff-20100127-r1.ebuild
index c13ddfb11313..1c89266a7936 100644
--- a/sci-electronics/puff/puff-20100127-r1.ebuild
+++ b/sci-electronics/puff/puff-20100127-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="microwave CAD software"
HOMEPAGE="https://wwwhome.cs.utwente.nl/~ptdeboer/ham/puff/"
@@ -22,13 +22,14 @@ src_prepare() {
# fix lib path for X11 and dont ignore LDFLAGS
sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
-e 's/CFLAGS/#CFLAGS/' \
+ -e 's/CC =/#CC =/' \
-e 's/link.res/.res/g' \
-e 's/.res pu/.res $(LDFLAGS) pu/' Makefile || die
}
src_compile() {
LDFLAGS="$(raw-ldflags)"
- emake -j1
+ emake -j1 CC="$(tc-getCC)"
}
src_install() {
diff --git a/sci-electronics/puff/puff-20181104.ebuild b/sci-electronics/puff/puff-20181104.ebuild
index 9d07d1e9fd6c..bf281406eae7 100644
--- a/sci-electronics/puff/puff-20181104.ebuild
+++ b/sci-electronics/puff/puff-20181104.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="microwave CAD software"
HOMEPAGE="https://wwwhome.cs.utwente.nl/~ptdeboer/ham/puff/"
@@ -21,13 +21,14 @@ src_prepare() {
default
# fix lib path for X11 and dont ignore LDFLAGS
sed -i -e 's/CFLAGS/#CFLAGS/' \
+ -e 's/CC =/#CC =/' \
-e 's/link.res/.res/g' \
-e 's/.res pu/.res $(LDFLAGS) pu/' Makefile || die
}
src_compile() {
LDFLAGS="$(raw-ldflags)"
- emake -j1
+ emake -j1 CC="$(tc-getCC)"
}
src_install() {