summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/pulseview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/pulseview')
-rw-r--r--sci-electronics/pulseview/Manifest1
-rw-r--r--sci-electronics/pulseview/metadata.xml8
-rw-r--r--sci-electronics/pulseview/pulseview-0.2.0.ebuild46
-rw-r--r--sci-electronics/pulseview/pulseview-9999.ebuild46
4 files changed, 101 insertions, 0 deletions
diff --git a/sci-electronics/pulseview/Manifest b/sci-electronics/pulseview/Manifest
new file mode 100644
index 000000000000..68d32e1e60a0
--- /dev/null
+++ b/sci-electronics/pulseview/Manifest
@@ -0,0 +1 @@
+DIST pulseview-0.2.0.tar.gz 148799 SHA256 feb5d33a0a91c989bfc39fa758195755e78e87c3cf445bb135a8c8d4f86bc1dd SHA512 f770510ceade6382de2d09ba7819a9b39623f3ccbbb4a3a64bb0a64f774d356583f6ad2812a845978d1eaf50dcbfd4688ceec3005d0b712a087d1f686d3c0301 WHIRLPOOL 31068fcebd4286d325db37327c351e8cbd00e095901c04a3d034c127b1272e7c463400a91683cbb64a775b86f5cf61411f1f809e7b4dcd76113ceeb63990eaa2
diff --git a/sci-electronics/pulseview/metadata.xml b/sci-electronics/pulseview/metadata.xml
new file mode 100644
index 000000000000..9ec6e5e675dc
--- /dev/null
+++ b/sci-electronics/pulseview/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+<use>
+ <flag name='decode'>Enable decoding of protocols while capturing</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-electronics/pulseview/pulseview-0.2.0.ebuild b/sci-electronics/pulseview/pulseview-0.2.0.ebuild
new file mode 100644
index 000000000000..cf87801f711c
--- /dev/null
+++ b/sci-electronics/pulseview/pulseview-0.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{3,4} )
+inherit eutils cmake-utils python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Qt based logic analyzer GUI for sigrok"
+HOMEPAGE="http://sigrok.org/wiki/PulseView"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+decode static"
+REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.28.0
+ >=sci-libs/libsigrok-0.3.0
+ dev-qt/qtgui:4
+ >=dev-libs/boost-1.42
+ decode? (
+ >=sci-libs/libsigrokdecode-0.3.0
+ ${PYTHON_DEPS}
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( HACKING NEWS README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_WERROR=TRUE
+ $(cmake-utils_use_enable decode DECODE)
+ $(cmake-utils_use_enable static STATIC_PKGDEPS_LIBS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-electronics/pulseview/pulseview-9999.ebuild b/sci-electronics/pulseview/pulseview-9999.ebuild
new file mode 100644
index 000000000000..cf87801f711c
--- /dev/null
+++ b/sci-electronics/pulseview/pulseview-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{3,4} )
+inherit eutils cmake-utils python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Qt based logic analyzer GUI for sigrok"
+HOMEPAGE="http://sigrok.org/wiki/PulseView"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+decode static"
+REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.28.0
+ >=sci-libs/libsigrok-0.3.0
+ dev-qt/qtgui:4
+ >=dev-libs/boost-1.42
+ decode? (
+ >=sci-libs/libsigrokdecode-0.3.0
+ ${PYTHON_DEPS}
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( HACKING NEWS README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_WERROR=TRUE
+ $(cmake-utils_use_enable decode DECODE)
+ $(cmake-utils_use_enable static STATIC_PKGDEPS_LIBS)
+ )
+ cmake-utils_src_configure
+}