summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-09-01 00:13:30 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-09-01 00:14:20 +1000
commit33814f126442ce28c190b45cf8b29f2e15ee3d6f (patch)
treed7e6df788975d80adca44dbc84c2877743a2900c /sci-electronics
parentnet-analyzer/nagios: version bump to v4.1.1. (diff)
downloadgentoo-33814f126442ce28c190b45cf8b29f2e15ee3d6f.tar.gz
gentoo-33814f126442ce28c190b45cf8b29f2e15ee3d6f.tar.bz2
gentoo-33814f126442ce28c190b45cf8b29f2e15ee3d6f.zip
sci-electronics/cirkuit: add patch fixing build failure with kde-base/kdelibs-4.14.11
Gentoo-bug: 559252 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/cirkuit/cirkuit-0.4.3-r1.ebuild1
-rw-r--r--sci-electronics/cirkuit/files/cirkuit-0.4.3-kdelibs-4.14.11.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/sci-electronics/cirkuit/cirkuit-0.4.3-r1.ebuild b/sci-electronics/cirkuit/cirkuit-0.4.3-r1.ebuild
index 8cd8e267687..7a297d8e6cb 100644
--- a/sci-electronics/cirkuit/cirkuit-0.4.3-r1.ebuild
+++ b/sci-electronics/cirkuit/cirkuit-0.4.3-r1.ebuild
@@ -30,6 +30,7 @@ RDEPEND="${DEPEND}
"
DOCS=( Changelog README )
+PATCHES=( "${FILESDIR}/${P}-kdelibs-4.14.11.patch" )
src_install() {
kde4-base_src_install
diff --git a/sci-electronics/cirkuit/files/cirkuit-0.4.3-kdelibs-4.14.11.patch b/sci-electronics/cirkuit/files/cirkuit-0.4.3-kdelibs-4.14.11.patch
new file mode 100644
index 00000000000..9332701ea92
--- /dev/null
+++ b/sci-electronics/cirkuit/files/cirkuit-0.4.3-kdelibs-4.14.11.patch
@@ -0,0 +1,12 @@
+--- po/CMakeLists.txt
++++ po/CMakeLists.txt
+@@ -1,3 +1,9 @@
++# The pofiles macro creates in some versions same name targets
++# which since cmake 2.8 leads to target clashes.
++# Hence force the old policy for all po directories.
++# http://public.kitware.com/Bug/view.php?id=12952
++cmake_policy(SET CMP0002 OLD)
++
+ find_package(Gettext REQUIRED)
+ if (NOT GETTEXT_MSGMERGE_EXECUTABLE)
+ MESSAGE(FATAL_ERROR "Please install msgmerge binary")