summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-09-01 19:03:45 +0200
committerSam James <sam@gentoo.org>2023-05-06 04:48:42 +0100
commit3b1e846ff1d0069ae6e028eab70777d08698c6ba (patch)
tree63743a50ed3cc233941778e653503b9bd54e7720 /sci-electronics
parentdev-python/nextinspace: new package, add 2.0.5, 9999 (diff)
downloadgentoo-3b1e846ff1d0069ae6e028eab70777d08698c6ba.tar.gz
gentoo-3b1e846ff1d0069ae6e028eab70777d08698c6ba.tar.bz2
gentoo-3b1e846ff1d0069ae6e028eab70777d08698c6ba.zip
sci-electronics/xnecview: new package, add 1.37
Closes: https://bugs.gentoo.org/136778 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/27107 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/xnecview/Manifest1
-rw-r--r--sci-electronics/xnecview/files/xnecview-tc-variables.patch29
-rw-r--r--sci-electronics/xnecview/metadata.xml17
-rw-r--r--sci-electronics/xnecview/xnecview-1.37.ebuild37
4 files changed, 84 insertions, 0 deletions
diff --git a/sci-electronics/xnecview/Manifest b/sci-electronics/xnecview/Manifest
new file mode 100644
index 000000000000..8a9aa6cdf579
--- /dev/null
+++ b/sci-electronics/xnecview/Manifest
@@ -0,0 +1 @@
+DIST xnecview-1.37.tgz 79005 BLAKE2B 505ba69b7ba77355f789b36af3e1df3719eb0a9179541d83a26285a0e5c84fc7b9b156bf4d586bfa28af0074819e397bf7441e39a819972c701e6487787c07d3 SHA512 6fc4beec1b9502d6084d4e412b8bb89d1deeaab5bfa6c0341cba1a899fb9a59eb1e7f9dfc61a97f2853ecff57c241dc9af993b176410799a07f113e3a60f75d7
diff --git a/sci-electronics/xnecview/files/xnecview-tc-variables.patch b/sci-electronics/xnecview/files/xnecview-tc-variables.patch
new file mode 100644
index 000000000000..cd8a5c7d04dd
--- /dev/null
+++ b/sci-electronics/xnecview/files/xnecview-tc-variables.patch
@@ -0,0 +1,29 @@
+diff -Naur xnecview-1.37.org/Makefile xnecview-1.37/Makefile
+--- xnecview-1.37.org/Makefile 2006-03-27 22:38:37.000000000 +0200
++++ xnecview-1.37/Makefile 2022-09-01 19:00:31.929015747 +0200
+@@ -3,11 +3,12 @@
+
+
+
+-CC = gcc
+-CFLAGS = -O2 -g -Wall `pkg-config gtk+-2.0 --cflags`
++CC ?= gcc
++CFLAGS ?= -O2 -g -Wall
++CFLAGS += `$(PKG_CONFIG) gtk+-2.0 --cflags`
+
+-LD = $(CC)
+-LDFLAGS = `pkg-config gtk+-2.0 --libs` -lm
++LD ?= $(CC)
++LDFLAGS += `$(PKG_CONFIG) gtk+-2.0 --libs` -lm
+
+ ifeq ($(PNG),yes)
+ CFLAGS += -DHAVE_LIBPNG
+@@ -20,7 +21,7 @@
+ all: xnecview
+
+ xnecview: $(OBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o xnecview
++ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) -o xnecview
+
+ xnecview.tgz: $(SRCS)
+ tar czvf xnecview.tgz COPYING README HISTORY Imakefile Imakefile_nopng Makefile $(SRCS) xnecview.h config.h xnecview.1x xnecview.man
diff --git a/sci-electronics/xnecview/metadata.xml b/sci-electronics/xnecview/metadata.xml
new file mode 100644
index 000000000000..2f6ad5330dc3
--- /dev/null
+++ b/sci-electronics/xnecview/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Xnecview is a program for visualizing the input and output files of the
+ NEC antenna simulation software. It runs on Linux/Unix systems with the
+ X window system.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-electronics/xnecview/xnecview-1.37.ebuild b/sci-electronics/xnecview/xnecview-1.37.ebuild
new file mode 100644
index 000000000000..b6663d9c542f
--- /dev/null
+++ b/sci-electronics/xnecview/xnecview-1.37.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A program for visualizing NEC2 input and output data"
+HOMEPAGE="https://www.pa3fwm.nl/software/xnecview/"
+SRC_URI="https://www.pa3fwm.nl/software/xnecview/xnecview-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=media-libs/libpng-1.6
+ x11-libs/gtk+:2
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-tc-variables.patch"
+)
+
+src_compile() {
+ tc-export CC LD PKG_CONFIG
+ emake
+}
+
+src_install() {
+ dobin xnecview
+ doman xnecview.1x
+ dodoc README
+ dodoc HISTORY
+}