summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-27 19:38:49 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-27 19:38:49 +0100
commitcacd77c7b29aa0a47797a4c0367217ced638640b (patch)
treecc7919d965030a51635c3a91e3d88cfc1f2a2e94 /sci-electronics
parentapp-text/krop: Add a snapshot of the qt5 branch (diff)
downloadgentoo-cacd77c7b29aa0a47797a4c0367217ced638640b.tar.gz
gentoo-cacd77c7b29aa0a47797a4c0367217ced638640b.tar.bz2
gentoo-cacd77c7b29aa0a47797a4c0367217ced638640b.zip
sci-electronics/klayout: Version bump. WIP, does not build with Qt 5.9, no keywords.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/klayout/Manifest1
-rw-r--r--sci-electronics/klayout/klayout-0.25.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-electronics/klayout/Manifest b/sci-electronics/klayout/Manifest
index 462a3e5d5718..8a5e5634f5b8 100644
--- a/sci-electronics/klayout/Manifest
+++ b/sci-electronics/klayout/Manifest
@@ -1 +1,2 @@
DIST klayout-0.24.10.tar.gz 11262007 BLAKE2B 85e8d325a56672e6ba328f5ebf793f3c977542ed857621e504983a77e7762d795bbde0f572fb0017328bdb5c11e453f0cd9decedf3629f8ff0f2a6a25daf28c2 SHA512 0043b91e2dae9321299c217697c93af27bc7d795209bdf95248eee3690b97728854f9f82cc95f77f05a2cfbcae6a716ae594fe2485e04ed0a3f5d950abc0a31b
+DIST klayout-0.25.tar.gz 16461165 BLAKE2B 321d5c03b49b922b051407767f72135d0ff7e3fb0fe5dd237e27ce6c42d2b847f0bc4d96ae551c51b6581c0d39eb71f7053c8814dcb7afdfd027a24af9d553fd SHA512 0c05b0786e7e1dbf8035cbb3888eff776c0b96a4fcf2ebbc3065fe43340ae020b6713c2e1d2e7ab5caaf64d7ec84bea9d691ba6c0aea88e93c957530d3d4d114
diff --git a/sci-electronics/klayout/klayout-0.25.ebuild b/sci-electronics/klayout/klayout-0.25.ebuild
new file mode 100644
index 000000000000..157da060047f
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.25.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+RUBY_OPTIONAL=no
+USE_RUBY="ruby22"
+# note: define maximally ONE implementation here
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit eutils multilib toolchain-funcs python-single-r1 ruby-ng
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/klayoutmatthias/${PN}.git"
+ inherit git-r3
+ EGIT_CHECKOUT_DIR=${WORKDIR}/all/${P}
+else
+ SRC_URI="http://www.klayout.org/downloads/source/${P}.tar.gz"
+# KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ ${PYTHON_DEPS}
+ $(ruby_implementations_depend)
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ ruby-ng_pkg_setup
+}
+
+each_ruby_configure() {
+ tc-export CC CXX AR LD RANLIB
+ export CFLAGS CXXFLAGS
+ ./build.sh \
+ -expert \
+ -dry-run \
+ -qmake "/usr/$(get_libdir)/qt5/bin/qmake" \
+ -ruby "${RUBY}" \
+ -python "${PYTHON}" \
+ -build . \
+ -bin "${T}/bin" \
+ -rpath "/usr/$(get_libdir)/klayout" \
+ -option "${MAKEOPTS}" \
+ -with-qtbinding \
+ -without-64bit-coord \
+ -qt5 || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ emake all
+}
+
+each_ruby_install() {
+ emake install
+
+ cd "${T}/bin" || die
+
+ dodir "/usr/$(get_libdir)/klayout"
+ mv lib* "${ED}/usr/$(get_libdir)/klayout/" || die
+
+ dobin *
+}