summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Uleysky <uleysky@gmail.com>2018-05-31 15:37:22 +1000
committerAmy Liffey <amynka@gentoo.org>2018-08-18 10:32:36 +0100
commit313d2aef432078db4a1d72fbb450d35066d4aa06 (patch)
tree08605f11e5f83fcc28caffa987211e7778bd099e /sci-geosciences/gmt/gmt-4.5.18.ebuild
parentmedia-libs/id3lib: EAPI-6 bump (diff)
downloadgentoo-313d2aef432078db4a1d72fbb450d35066d4aa06.tar.gz
gentoo-313d2aef432078db4a1d72fbb450d35066d4aa06.tar.bz2
gentoo-313d2aef432078db4a1d72fbb450d35066d4aa06.zip
sci-geosciences/gmt: version bump 4.5.18
Closes: https://github.com/gentoo/gentoo/pull/9454
Diffstat (limited to 'sci-geosciences/gmt/gmt-4.5.18.ebuild')
-rw-r--r--sci-geosciences/gmt/gmt-4.5.18.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/sci-geosciences/gmt/gmt-4.5.18.ebuild b/sci-geosciences/gmt/gmt-4.5.18.ebuild
new file mode 100644
index 000000000000..9730b119d3cb
--- /dev/null
+++ b/sci-geosciences/gmt/gmt-4.5.18.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+GSHHG="gshhg-gmt-2.3.7"
+
+DESCRIPTION="Powerful map generator"
+HOMEPAGE="https://gmt.soest.hawaii.edu/"
+SRC_URI="
+ mirror://gmt/${P}-src.tar.bz2
+ mirror://gmt/${GSHHG}.tar.gz
+ gmttria? ( mirror://gmt/${P}-non-gpl-src.tar.bz2 )"
+
+LICENSE="GPL-2 gmttria? ( Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +gdal gmttria +metric mex +netcdf octave postscript"
+
+RDEPEND="
+ !sci-biology/probcons
+ gdal? ( sci-libs/gdal )
+ netcdf? ( >=sci-libs/netcdf-4.1 )
+ octave? ( sci-mathematics/octave )"
+DEPEND="${RDEPEND}"
+
+# mex can use matlab too which i can't test
+REQUIRED_USE="
+ mex? ( octave )
+"
+
+# hand written make files that are not parallel safe
+MAKEOPTS+=" -j1"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.9-no-strip.patch
+ "${FILESDIR}"/${PN}-4.5.6-respect-ldflags.patch
+ )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ default
+
+ mkdir "${S}/share/coast" || die
+ mv -f "${WORKDIR}/${GSHHG}/"*.nc "${S}/share/coast/" || die
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/${P} \
+ --includedir=/usr/include/${P} \
+ --datadir=/usr/share/${P} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-update \
+ --disable-matlab \
+ --disable-xgrid \
+ --disable-debug \
+ $(use_enable gdal) \
+ $(use_enable netcdf) \
+ $(use_enable octave) \
+ $(use_enable debug devdebug) \
+ $(use_enable !metric US) \
+ $(use_enable postscript eps) \
+ $(use_enable mex) \
+ $(use_enable gmttria triangle)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-all
+ einstalldocs
+
+ docompress -x /usr/share/doc/${PF}/{examples,tutorial}
+
+ # remove static libs
+ find "${ED}/usr/$(get_libdir)" -name '*.a' -exec rm -f {} + || die
+
+ cat <<- _EOF_ > "${T}/99gmt"
+ GMTHOME="${EPREFIX}/usr/share/${P}"
+ GMT_SHAREDIR="${EPREFIX}/usr/share/${P}"
+ _EOF_
+ doenvd "${T}/99gmt"
+}