summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gtk-g-rays2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gtk-g-rays2')
-rw-r--r--sci-geosciences/gtk-g-rays2/Manifest2
-rw-r--r--sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.01.ebuild44
-rw-r--r--sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild45
-rw-r--r--sci-geosciences/gtk-g-rays2/metadata.xml8
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-geosciences/gtk-g-rays2/Manifest b/sci-geosciences/gtk-g-rays2/Manifest
new file mode 100644
index 000000000000..a699484c3930
--- /dev/null
+++ b/sci-geosciences/gtk-g-rays2/Manifest
@@ -0,0 +1,2 @@
+DIST gtk-g-rays2-2.01.tar.xz 650456 SHA256 b0fbbc036146ea84a944eb7d33246198579383527a1fb01d42bce9b7913e7d7b SHA512 d8b3cd232fca1286078013003bb35be49a4957a520509a8b73f51e6c533430df9042883e27fd3f68868b656b9c09d4ad257825b2f03595a70013f4daf0269309 WHIRLPOOL ab5f3056b3afd7c7e82a5e78fb9b946a145ba73a7a5575bfdd5376b838149ca62f3e2aeb0357b1efee6f50ddd8c0e2ab6ba42b37a6da4378e96f6a4b2f155d5f
+DIST gtk-g-rays2-2.05.tar.xz 898216 SHA256 1bd9bfe70e601da4bd0a7ab3072e95b477ec87df03c69ece5fbfc3a0308e0d3c SHA512 673d6e756f1a827e1c0de5384f3228e69a00a56588b81528202e80f5d2067213fd9fdb5af22028fcce0c4ea9e4d1b708accdd5777628ded351e3f2b6f2f57e41 WHIRLPOOL 2dea98ed42d55d2e04c22ea8353c486ebe76aa2e22f4a4b24775c56df913b182ff7b45a5149ae08474fc0c06ab47be6fdecb49822be794dc8af881eed8d4f1ab
diff --git a/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.01.ebuild b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.01.ebuild
new file mode 100644
index 000000000000..3529d5945f9b
--- /dev/null
+++ b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.01.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools gnome2
+
+DESCRIPTION="GUI for accessing the Wintec WBT 201 / G-Rays 2 GPS device"
+HOMEPAGE="http://www.daria.co.uk/gps"
+SRC_URI="http://www.zen35309.zen.co.uk/gps/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ virtual/libgudev
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOCS="README AUTHORS ChangeLog"
+
+src_prepare() {
+ # werror is bad idea
+ sed -i -e 's:-Werror::g' configure.ac || die
+ # we run this ourselves
+ sed -i -e '/gtk-update-icon-cache/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
diff --git a/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild
new file mode 100644
index 000000000000..a14ed48a17af
--- /dev/null
+++ b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools gnome2
+
+DESCRIPTION="GUI for accessing the Wintec WBT 201 / G-Rays 2 GPS device"
+HOMEPAGE="http://www.daria.co.uk/gps"
+SRC_URI="http://www.zen35309.zen.co.uk/gps/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ virtual/libgudev
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ virtual/freedesktop-icon-theme
+ net-wireless/bluez
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOCS="README AUTHORS ChangeLog"
+
+src_prepare() {
+ # werror is bad idea
+ sed -i -e 's:-Werror::g' configure.ac || die
+ # we run this ourselves
+ sed -i -e '/gtk-update-icon-cache/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
diff --git a/sci-geosciences/gtk-g-rays2/metadata.xml b/sci-geosciences/gtk-g-rays2/metadata.xml
new file mode 100644
index 000000000000..3beda91ba209
--- /dev/null
+++ b/sci-geosciences/gtk-g-rays2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>