summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-08-04 10:43:56 +0100
committerAmy Liffey <amynka@gentoo.org>2018-08-04 10:47:06 +0100
commita48080e87547149f113585606aa9185aa5d2a70c (patch)
tree504f1a3b429e7ea403a1020b33e6edf23933e765 /sci-geosciences/mapnik
parentapp-xemacs/clearcase: version bump (diff)
downloadgentoo-a48080e87547149f113585606aa9185aa5d2a70c.tar.gz
gentoo-a48080e87547149f113585606aa9185aa5d2a70c.tar.bz2
gentoo-a48080e87547149f113585606aa9185aa5d2a70c.zip
sci-geosciences/mapnik: remove unneeded patch, old 3.0.9
Closes: https://bugs.gentoo.org/635462 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-geosciences/mapnik')
-rw-r--r--sci-geosciences/mapnik/files/mapnik-2.2.0-scons.patch11
-rw-r--r--sci-geosciences/mapnik/mapnik-3.0.9-r1.ebuild3
-rw-r--r--sci-geosciences/mapnik/mapnik-3.0.9.ebuild104
3 files changed, 1 insertions, 117 deletions
diff --git a/sci-geosciences/mapnik/files/mapnik-2.2.0-scons.patch b/sci-geosciences/mapnik/files/mapnik-2.2.0-scons.patch
deleted file mode 100644
index 0ddcd0f9e0dd..000000000000
--- a/sci-geosciences/mapnik/files/mapnik-2.2.0-scons.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/SConstruct
-+++ b/SConstruct
-@@ -291,7 +291,7 @@ opts.AddVariables(
- ('LINK_PRIORITY','Priority list in which to sort library and include paths (default order is internal, other, frameworks, user, then system - see source of `sort_paths` function for more detail)',','.join(DEFAULT_LINK_PRIORITY)),
-
- # Install Variables
-- ('PREFIX', 'The install path "prefix"', '/usr/local'),
-+ ('PREFIX', 'The install path "prefix"', '/usr'),
- ('LIBDIR_SCHEMA', 'The library sub-directory appended to the "prefix", sometimes lib64 on 64bit linux systems', LIBDIR_SCHEMA_DEFAULT),
- ('PYTHON_PREFIX','Custom install path "prefix" for python bindings (default of no prefix)',''),
- ('DESTDIR', 'The root directory to install into. Useful mainly for binary package building', '/'),
diff --git a/sci-geosciences/mapnik/mapnik-3.0.9-r1.ebuild b/sci-geosciences/mapnik/mapnik-3.0.9-r1.ebuild
index 9ed3676d7c4b..189477aa4147 100644
--- a/sci-geosciences/mapnik/mapnik-3.0.9-r1.ebuild
+++ b/sci-geosciences/mapnik/mapnik-3.0.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,7 +40,6 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-2.2.0-configure-only-once.patch"
"${FILESDIR}/${PN}-2.2.0-dont-run-ldconfig.patch"
- "${FILESDIR}/${PN}-2.2.0-scons.patch"
"${FILESDIR}/${P}-harbuzz_sharper-upstream.patch" # upstream patches ported from
"${FILESDIR}/${P}-unicode-upstream.patch" # https://github.com/mapnik/mapnik/commit/9e58c890430db6f0b6f1f7a1690877c9d913d92a
)
diff --git a/sci-geosciences/mapnik/mapnik-3.0.9.ebuild b/sci-geosciences/mapnik/mapnik-3.0.9.ebuild
deleted file mode 100644
index ae28bff85588..000000000000
--- a/sci-geosciences/mapnik/mapnik-3.0.9.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils scons-utils toolchain-funcs
-
-DESCRIPTION="A Free Toolkit for developing mapping applications"
-HOMEPAGE="http://www.mapnik.org/"
-SRC_URI="https://github.com/mapnik/mapnik/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cairo debug doc gdal postgres sqlite"
-
-RDEPEND="
- >=dev-libs/boost-1.48[threads]
- dev-libs/icu:=
- sys-libs/zlib
- media-libs/freetype
- media-libs/harfbuzz
- dev-libs/libxml2
- media-libs/libpng:0=
- media-libs/tiff:0=
- virtual/jpeg:0=
- media-libs/libwebp
- sci-libs/proj
- media-fonts/dejavu
- x11-libs/agg[truetype]
- cairo? (
- x11-libs/cairo
- dev-cpp/cairomm
- )
- postgres? ( >=dev-db/postgresql-8.3:* )
- gdal? ( sci-libs/gdal )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.0-configure-only-once.patch"
- "${FILESDIR}/${PN}-2.2.0-dont-run-ldconfig.patch"
- "${FILESDIR}/${PN}-2.2.0-scons.patch"
-)
-
-src_prepare() {
- default
-
- # do not version epidoc data
- sed -i \
- -e 's:-`mapnik-config --version`::g' \
- utils/epydoc_config/build_epydoc.sh || die
-
- # force user flags, optimization level
- sed -i -e "s:\-O%s:%s:" \
- -i -e "s:env\['OPTIMIZATION'\]:'${CXXFLAGS}':" \
- SConstruct || die
-}
-
-src_configure() {
- local PLUGINS=shape,csv,raster,geojson
- use gdal && PLUGINS+=,gdal,ogr
- use postgres && PLUGINS+=,postgis
- use sqlite && PLUGINS+=,sqlite
-
- MYSCONS=(
- "CC=$(tc-getCC)"
- "CXX=$(tc-getCXX)"
- "INPUT_PLUGINS=${PLUGINS}"
- "PREFIX=/usr"
- "DESTDIR=${D}"
- "XMLPARSER=libxml2"
- "LINKING=shared"
- "RUNTIME_LINK=shared"
- "PROJ_INCLUDES=/usr/include"
- "PROJ_LIBS=/usr/$(get_libdir)"
- "SYSTEM_FONTS=/usr/share/fonts"
- CAIRO="$(usex cairo 1 0)"
- DEBUG="$(usex debug 1 0)"
- XML_DEBUG="$(usex debug 1 0)"
- DEMO="$(usex doc 1 0)"
- SAMPLE_INPUT_PLUGINS="$(usex doc 1 0)"
- "CUSTOM_LDFLAGS=${LDFLAGS}"
- "CUSTOM_LDFLAGS+=-L${ED}/usr/$(get_libdir)"
- )
- escons "${MYSCONS[@]}" configure
-}
-
-src_compile() {
- escons "${MYSCONS[@]}"
-}
-
-src_install() {
- escons "${MYSCONS[@]}" DESTDIR="${D}" install
-
- dodoc AUTHORS.md README.md CHANGELOG.md
-}
-
-pkg_postinst() {
- elog ""
- elog "See the home page or wiki (https://github.com/mapnik/mapnik/wiki) for more info"
- elog "or the installed examples for the default mapnik ogcserver config."
- elog ""
-}