summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-12-18 10:08:45 +1100
committerSam Jorna <wraeth@gentoo.org>2016-12-18 10:09:35 +1100
commitceba01e641ac710cdfe813e43226cf693bf7e8cc (patch)
treef7bc96387b3a2b91fae013a4c0f07067015f0da8 /sci-geosciences/mapserver
parentapp-shells/hstr: clean up old. (diff)
downloadgentoo-ceba01e641ac710cdfe813e43226cf693bf7e8cc.tar.gz
gentoo-ceba01e641ac710cdfe813e43226cf693bf7e8cc.tar.bz2
gentoo-ceba01e641ac710cdfe813e43226cf693bf7e8cc.zip
sci-geosciences/mapserver: bump to 7.0.3 #602616
Version bump to 7.0.3. Resolves information leakage from OGR driver. Remove PHP5.5. Gentoo-bug: 602616 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences/mapserver')
-rw-r--r--sci-geosciences/mapserver/Manifest2
-rw-r--r--sci-geosciences/mapserver/mapserver-7.0.3.ebuild (renamed from sci-geosciences/mapserver/mapserver-7.0.1-r1.ebuild)16
2 files changed, 14 insertions, 4 deletions
diff --git a/sci-geosciences/mapserver/Manifest b/sci-geosciences/mapserver/Manifest
index c4d472d04df5..c93b27c62cfd 100644
--- a/sci-geosciences/mapserver/Manifest
+++ b/sci-geosciences/mapserver/Manifest
@@ -1 +1 @@
-DIST mapserver-7.0.1.tar.gz 2606929 SHA256 2c9567e59ae3ebd99bb645740485be6a25798b8b57f93ca3413a3e0369a1bd8f SHA512 10cf58920a3083280a748efa087f105ed2e29650d10b56b7d457c46fd7fc4670a021db1aa27186997aaa3ea1b6a5b2772f2ffc5d8de48130f5ebed654215f2df WHIRLPOOL 0ef70bd312aba706c19ebc8d324e9ac2bc72bb400cbdb539c20ca0ea383744f363425dbc2dc1b70f8e133b0e84409645505a880f2e5689345e8c7bd7c5e952d5
+DIST mapserver-7.0.3.tar.gz 2621285 SHA256 dbec8f0ccdf506e7117cec5b704e8f9692451f72a07d9f4879d508ed96c55550 SHA512 7630461948e7b371c6d4d6d49cc596ad8fc6b076a8bbfdc88358fc076fa0d4ebaaab10663ec9c3c64e246b5735a07cef5cc28eba88b00dd09259048a49d2b81b WHIRLPOOL 4306a29758ae2b8f6acaf5f8c9157f0851a028f25fba4cd130022d37b5f31e35f486be49b4393351123f5e9923ab2c342430d33dc15e4b07c0904c3bcad7e259
diff --git a/sci-geosciences/mapserver/mapserver-7.0.1-r1.ebuild b/sci-geosciences/mapserver/mapserver-7.0.3.ebuild
index 0392bd6d9b5f..4010edaf3c93 100644
--- a/sci-geosciences/mapserver/mapserver-7.0.1-r1.ebuild
+++ b/sci-geosciences/mapserver/mapserver-7.0.3.ebuild
@@ -10,7 +10,7 @@ PHP_EXT_OPTIONAL_USE="php"
PHP_EXT_NAME="php_mapscript"
PHP_EXT_S="${WORKDIR}/${MY_P}/mapscript/php/"
PHP_EXT_SKIP_PHPIZE="no"
-USE_PHP="php5-6 php5-5"
+USE_PHP="php5-6"
PYTHON_COMPAT=( python2_7 )
@@ -30,7 +30,7 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="bidi cairo gdal geos mysql opengl perl php postgis proj python threads tiff xml xslt" # ruby php tcl
-REQUIRED_USE="php? ( ^^ ( php_targets_php5-6 php_targets_php5-5 ) )
+REQUIRED_USE="php? ( php_targets_php5-6 )
xslt? ( xml )"
RDEPEND="
@@ -153,7 +153,17 @@ src_configure() {
if use php ; then
local slot
for slot in $(php_get_slots); do
- mycmakeargs+=( -DPHP5_CONFIG_EXECUTABLE="${EPREFIX}/usr/$(get_libdir)/${slot}/bin/php-config" )
+ local php_config="${EPREFIX}/usr/$(get_libdir)/${slot}/bin/php-config"
+ [[ -x ${php_config} ]] \
+ || die "php-config '${php_config}' not valid or not executable"
+
+ local php_include_dir=$(${php_config} --include-dir)
+ [[ -d ${php_include_dir} ]] || die "PHP Include dir not found or not valid"
+
+ mycmakeargs+=(
+ -DPHP5_CONFIG_EXECUTABLE="${php_config}"
+ -DPHP5_INCLUDES="${php_include_dir}"
+ )
done
fi