summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 18:16:05 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 18:16:17 +0100
commitaa70c867432f44ac7185a1ab2fa1ded96eb5ccaa (patch)
tree81cf93a2a06e20a4b5eb13277e08aa75f9866b4e /sci-geosciences/opencpn-plugin-br24radar
parentnet-analyzer/tcpreplay: Old. (diff)
downloadgentoo-aa70c867432f44ac7185a1ab2fa1ded96eb5ccaa.tar.gz
gentoo-aa70c867432f44ac7185a1ab2fa1ded96eb5ccaa.tar.bz2
gentoo-aa70c867432f44ac7185a1ab2fa1ded96eb5ccaa.zip
sci-geosciences/opencpn-plugin-br24radar: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'sci-geosciences/opencpn-plugin-br24radar')
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.1-r1.ebuild b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.1-r1.ebuild
new file mode 100644
index 000000000000..c2fcdd74f1b6
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-1.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+inherit cmake-utils wxwidgets
+
+MY_PN="BR24radar_pi"
+
+DESCRIPTION="Navico (Simrad, Lowrance) Broadband BR24/3G/4G Radar Plugin for OpenCPN"
+HOMEPAGE="http://opencpn-navico-radar-plugin.github.io/"
+SRC_URI="
+ https://github.com/canboat/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.0.0
+ sys-devel/gettext
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}