summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/opencpn-plugin-ocpndebugger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/opencpn-plugin-ocpndebugger')
-rw-r--r--sci-geosciences/opencpn-plugin-ocpndebugger/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-ocpndebugger/metadata.xml12
-rw-r--r--sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-ocpndebugger/Manifest b/sci-geosciences/opencpn-plugin-ocpndebugger/Manifest
new file mode 100644
index 000000000000..a1575c44d51a
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-ocpndebugger/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-ocpndebugger-1.0.tar.gz 109976 SHA256 519b7cf341932c31205772d89a27682622d038479e4f76135534d5b87aea145f SHA512 0230d123a706b136269d81a509bb64262c3b007d0d7b944089bb4bd113a56217cf0321ea82b170ce1ca8d3b4b08b996d09a088137c4d1817bb795ed4de50f6dd WHIRLPOOL d89d46d5239a0083028338faa39d17c1b7d24bbb4e989d11d4e9430f774c97c90a8ad66d1c0b6e61cec869db36dade2e7c62a1fee7b8346f5e3fd03b5c97da8f
diff --git a/sci-geosciences/opencpn-plugin-ocpndebugger/metadata.xml b/sci-geosciences/opencpn-plugin-ocpndebugger/metadata.xml
new file mode 100644
index 000000000000..dc938a7ae9ef
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-ocpndebugger/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nohal/ocpndebugger_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild b/sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild
new file mode 100644
index 000000000000..1f9c78cf8510
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-ocpndebugger/opencpn-plugin-ocpndebugger-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+inherit cmake-utils wxwidgets
+
+MY_PN="ocpndebugger_pi"
+
+DESCRIPTION="NMEA-data and plugin-API Debugger Plugin for OpenCPN"
+HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
+SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-geosciences/opencpn-4.0.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"