summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-24 13:07:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-24 15:18:03 +0200
commitda09f45c7dbdb3760cdbc304c70b73ebfaa63f64 (patch)
treec50d99245929d9c003f3a7fe19f9ad65d8742135 /sci-geosciences/qgis
parentsci-geosciences/qgis: Disable ccache (diff)
downloadgentoo-da09f45c7dbdb3760cdbc304c70b73ebfaa63f64.tar.gz
gentoo-da09f45c7dbdb3760cdbc304c70b73ebfaa63f64.tar.bz2
gentoo-da09f45c7dbdb3760cdbc304c70b73ebfaa63f64.zip
sci-geosciences/qgis: Add USE=qml
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-geosciences/qgis')
-rw-r--r--sci-geosciences/qgis/metadata.xml1
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index f25562d2fc93..162cbbaa3dec 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -19,5 +19,6 @@
<flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
<flag name="mapserver">Determines whether mapserver should be built</flag>
<flag name="polar">Enable support for the polar coordinate system via <pkg>x11-libs/qwtpolar</pkg></flag>
+ <flag name="qml">Enable support Qml-based plugins using <pkg>dev-qt/qtdeclarative</pkg></flag>
</use>
</pkgmetadata>
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index efdffd875188..7ea4905841a8 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -23,7 +23,7 @@ HOMEPAGE="https://www.qgis.org/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass mapserver oracle polar postgres python webkit"
+IUSE="3d examples georeferencer grass mapserver oracle polar postgres python qml webkit"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -80,6 +80,7 @@ COMMON_DEPEND="
>=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
)
+ qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
"
DEPEND="${COMMON_DEPEND}
@@ -144,6 +145,7 @@ src_configure() {
-DWITH_POSTGRESQL=$(usex postgres)
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
+ -DWITH_QUICK=$(usex qml)
-DWITH_QTWEBKIT=$(usex webkit)
)