summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-28 00:22:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-28 17:26:44 +0200
commit09b59bc06697355114cfd40a521e379a1cbdcec6 (patch)
treeab6c141ba3db6a69eec1536dbedfd6d0ca9bc5a2 /sci-geosciences
parentsci-geosciences/qgis: Add new DEPEND on virtual/opencl (diff)
downloadgentoo-09b59bc06697355114cfd40a521e379a1cbdcec6.tar.gz
gentoo-09b59bc06697355114cfd40a521e379a1cbdcec6.tar.bz2
gentoo-09b59bc06697355114cfd40a521e379a1cbdcec6.zip
sci-geosciences/qgis: Set WITH_INTERNAL_MDAL=ON, add USE hdf5, netcdf
As long as sci-libs/mdal is not packaged. Upstream commits: 50422a116516cfb7e05f2e60062eb9d7555592ae 14fa499ed3ce0358dd4835cd1f43b4b93df8f473 97c95803c623f234b13a921325b050f235170d00 Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/metadata.xml2
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild7
2 files changed, 8 insertions, 1 deletions
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index 868a026b6c1e..56b0fd7a351e 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -17,7 +17,9 @@
<flag name="3d">Build QGIS 3D library using <pkg>dev-qt/qt3d</pkg></flag>
<flag name="georeferencer">Determines whether georeferencer plugin should be built</flag>
<flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
+ <flag name="hdf5">Enable MDAL support for <pkg>sci-libs/hdf5</pkg></flag>
<flag name="mapserver">Determines whether mapserver should be built</flag>
+ <flag name="netcdf">Enable MDAL support for GRIB and XMDF formats</flag>
<flag name="opencl">Enable OpenCL support</flag>
<flag name="polar">Enable support for the polar coordinate system via <pkg>x11-libs/qwtpolar</pkg></flag>
<flag name="qml">Enable support Qml-based plugins using <pkg>dev-qt/qtdeclarative</pkg></flag>
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index ab077fc720a4..6aa2463ff1cd 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://www.qgis.org/"
LICENSE="GPL-2+ GPL-3+"
SLOT="0"
-IUSE="3d examples georeferencer grass mapserver opencl oracle polar postgres python qml webkit"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml webkit"
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
@@ -59,7 +59,9 @@ COMMON_DEPEND="
3d? ( >=dev-qt/qt3d-${QT_MIN_VER}:5 )
georeferencer? ( sci-libs/gsl:= )
grass? ( =sci-geosciences/grass-7*:= )
+ hdf5? ( sci-libs/hdf5:= )
mapserver? ( dev-libs/fcgi )
+ netcdf? ( sci-libs/netcdf:= )
opencl? ( virtual/opencl )
oracle? (
dev-db/oracle-instantclient:=
@@ -126,12 +128,15 @@ src_configure() {
-DPEDANTIC=OFF
-DUSE_CCACHE=OFF
-DWITH_APIDOC=OFF
+ -DWITH_INTERNAL_MDAL=ON # not packaged, bug 684538
-DWITH_QSPATIALITE=ON
-DENABLE_TESTS=OFF
-DWITH_3D=$(usex 3d)
-DWITH_GEOREFERENCER=$(usex georeferencer)
-DWITH_GRASS7=$(usex grass)
+ $(cmake-utils_use_find_package hdf5 HDF5)
-DWITH_SERVER=$(usex mapserver)
+ $(cmake-utils_use_find_package netcdf NetCDF)
-DUSE_OPENCL=$(usex opencl)
-DWITH_ORACLE=$(usex oracle)
-DWITH_QWTPOLAR=$(usex polar)