summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-23 23:14:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-23 23:22:24 +0100
commit4253275cb926d196b7a3566ff28a8cf756ae8138 (patch)
treea4c3f17a26d4d46081a233b7551f40645901be40 /sci-geosciences
parentapp-text/fbpdf: bump to support mupdf-1.10, bug #606876 (diff)
downloadgentoo-4253275cb926d196b7a3566ff28a8cf756ae8138.tar.gz
gentoo-4253275cb926d196b7a3566ff28a8cf756ae8138.tar.bz2
gentoo-4253275cb926d196b7a3566ff28a8cf756ae8138.zip
sci-geosciences/gpsbabel: Drop USE=qt5
Gentoo-bug: 606952 The buildsystem does not properly support that case. Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.5.4.ebuild61
1 files changed, 26 insertions, 35 deletions
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.5.4.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.5.4.ebuild
index 01af5b84910..324948b8d3f 100644
--- a/sci-geosciences/gpsbabel/gpsbabel-1.5.4.ebuild
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.5.4.ebuild
@@ -15,30 +15,28 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc qt5"
+IUSE="doc"
RDEPEND="
dev-libs/expat
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
sci-libs/shapelib:=
sys-libs/zlib[minizip]
virtual/libusb:0
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwebchannel:5
- dev-qt/qtwebengine:5[widgets]
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- )
"
DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
doc? (
dev-lang/perl
dev-libs/libxslt
app-text/docbook-xml-dtd:4.1.2
)
- qt5? ( dev-qt/linguist:5 )
"
DOCS=( AUTHORS README.{contrib,igc,mapconverter,md,xmapwpt} )
@@ -73,26 +71,23 @@ src_prepare() {
src_configure() {
econf \
$(use_with doc doc "${S}"/doc/manual) \
- $(usex qt5 LRELEASE=$(qt5_get_bindir)/lrelease '') \
- $(usex qt5 LUPDATE=$(qt5_get_bindir)/lupdate '') \
- $(usex qt5 QMAKE=$(qt5_get_bindir)/qmake '') \
+ LRELEASE=$(qt5_get_bindir)/lrelease \
+ LUPDATE=$(qt5_get_bindir)/lupdate \
+ QMAKE=$(qt5_get_bindir)/qmake \
--with-zlib=system
- if use qt5; then
- pushd "${S}/gui" > /dev/null || die
- lrelease *.ts || die
- eqmake5
- popd > /dev/null
- fi
+ pushd "${S}/gui" > /dev/null || die
+ lrelease *.ts || die
+ eqmake5
+ popd > /dev/null
}
src_compile() {
default
- if use qt5; then
- pushd "${S}/gui" > /dev/null || die
- emake
- popd > /dev/null
- fi
+
+ pushd "${S}/gui" > /dev/null || die
+ emake
+ popd > /dev/null
if use doc; then
perl xmldoc/makedoc || die
@@ -101,17 +96,13 @@ src_compile() {
}
src_install() {
- if use doc; then
- HTML_DOCS=( "${S}"/${PN}.html "${S}"/${PN}.org-style3.css )
- fi
+ use doc && HTML_DOCS=( "${S}"/${PN}.html "${S}"/${PN}.org-style3.css )
default
- if use qt5; then
- dobin gui/objects/gpsbabelfe
- insinto /usr/share/${PN}/translations/
- doins gui/gpsbabel*_*.qm
- newicon gui/images/appicon.png ${PN}.png
- make_desktop_entry gpsbabelfe ${PN} ${PN} "Science;Geoscience"
- fi
+ dobin gui/objects/gpsbabelfe
+ insinto /usr/share/${PN}/translations/
+ doins gui/gpsbabel*_*.qm
+ newicon gui/images/appicon.png ${PN}.png
+ make_desktop_entry gpsbabelfe ${PN} ${PN} "Science;Geoscience"
}