summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:24:24 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commit81c669601b2a2951492023c0ac26b773bde1c9e7 (patch)
treec55286d71d3a48a0b565b88dac2ade78df31f11d /sci-geosciences
parentsci-geosciences/opencpn-plugin-ocpn_draw: added ebuild (diff)
downloadgentoo-81c669601b2a2951492023c0ac26b773bde1c9e7.tar.gz
gentoo-81c669601b2a2951492023c0ac26b773bde1c9e7.tar.bz2
gentoo-81c669601b2a2951492023c0ac26b773bde1c9e7.zip
sci-geosciences/opencpn-plugin-otcurrent: added new ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild38
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild38
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/Manifest b/sci-geosciences/opencpn-plugin-otcurrent/Manifest
new file mode 100644
index 000000000000..27b3ba950611
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-otcurrent/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-otcurrent-1.2.tar.gz 184391 SHA256 808323caa3c120471e50d418e969a0c15206b87a1d05c10bc7002d61fbfb09ed SHA512 04564e0fcafe0f338d52a2fe7cf1a00c5d53d4ecbbac3264203ddc5ed4dd1e237b45d206314dfc493ea4649491a03872158a4d61a6dd0658dd54a20b43502263 WHIRLPOOL f2203e98939a2884caf33111151743518af7edd6603d87ceb4dca4ba588d3acb4b60789bd84c6ca05673ab9fff59e51c6b7deaa87bceb4cb00226948df5d0fe2
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/metadata.xml b/sci-geosciences/opencpn-plugin-otcurrent/metadata.xml
new file mode 100644
index 000000000000..37fc2f734d5a
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-otcurrent/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Rasbats/otcurrent_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
new file mode 100644
index 000000000000..7079ab516cd5
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="otcurrent_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="IAC Fleetcode Plugin for OpenCPN"
+HOMEPAGE="https://github.com/Rasbats/otcurrent_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
new file mode 100644
index 000000000000..7079ab516cd5
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="otcurrent_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="IAC Fleetcode Plugin for OpenCPN"
+HOMEPAGE="https://github.com/Rasbats/otcurrent_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}