summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-24 12:48:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-24 15:18:02 +0200
commite12ccf4e38b42bd4e4dd118eb6010bd7edb79002 (patch)
tree1dfa45091858d20593b5c89908246334878ca5fa /sci-geosciences
parentdev-python/hiredis: Fix linking (#653790 by Ștefan Talpalaru) (diff)
downloadgentoo-e12ccf4e38b42bd4e4dd118eb6010bd7edb79002.tar.gz
gentoo-e12ccf4e38b42bd4e4dd118eb6010bd7edb79002.tar.bz2
gentoo-e12ccf4e38b42bd4e4dd118eb6010bd7edb79002.zip
sci-geosciences/qgis: Always depend on python
Reported-by: Sławomir Nizio <slawomir.nizio@sabayon.org> Thanks-to: Kalin KOZHUHAROV <kalin@ThinRope.net> Closes: https://bugs.gentoo.org/658250 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index 0b888637f800..a64e21fa38a9 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -25,10 +25,7 @@ LICENSE="GPL-2+ GPL-3+"
SLOT="0"
IUSE="3d examples georeferencer grass mapserver oracle polar postgres python webkit"
-REQUIRED_USE="
- grass? ( python )
- mapserver? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
COMMON_DEPEND="
app-crypt/qca:2[qt5(+),ssl]
@@ -48,7 +45,7 @@ COMMON_DEPEND="
>=dev-qt/qtsql-${QT_MIN_VER}:5
>=dev-qt/qtwidgets-${QT_MIN_VER}:5
>=dev-qt/qtxml-${QT_MIN_VER}:5
- >=sci-libs/gdal-2.2.3:=[geos,python?,${PYTHON_USEDEP}]
+ >=sci-libs/gdal-2.2.3:=[geos]
sci-libs/geos
sci-libs/libspatialindex:=
sci-libs/proj
@@ -64,7 +61,8 @@ COMMON_DEPEND="
)
polar? ( >=x11-libs/qwtpolar-1.1.1-r1[qt5(+)] )
postgres? ( dev-db/postgresql:= )
- python? ( ${PYTHON_DEPS}
+ python? (
+ ${PYTHON_DEPS}
dev-python/future[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
@@ -79,6 +77,7 @@ COMMON_DEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/sip:=[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
)
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
@@ -89,6 +88,7 @@ DEPEND="${COMMON_DEPEND}
>=dev-qt/qtxmlpatterns-${QT_MIN_VER}:5
sys-devel/bison
sys-devel/flex
+ python? ( ${PYTHON_DEPS} )
"
RDEPEND="${COMMON_DEPEND}
sci-geosciences/gpsbabel
@@ -105,7 +105,7 @@ PATCHES=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {
@@ -187,10 +187,10 @@ src_install() {
if use python; then
python_optimize "${ED%/}"/usr/share/qgis/python
+ fi
- if use grass; then
- python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
- fi
+ if use grass; then
+ python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
fi
}