summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2016-10-08 21:18:45 +0200
committerSlawomir Lis <slis@gentoo.org>2016-10-08 21:18:45 +0200
commit6ca7c50770c9b703fa101770b93c544576147fad (patch)
tree35ed4667c890eb6f1de577e0850af70df64eba34 /sci-libs/Shapely
parentwww-client/firefox: added cak, dsb, ff, gn, lij to supported L10N list (diff)
downloadgentoo-6ca7c50770c9b703fa101770b93c544576147fad.tar.gz
gentoo-6ca7c50770c9b703fa101770b93c544576147fad.tar.bz2
gentoo-6ca7c50770c9b703fa101770b93c544576147fad.zip
sci-libs/Shapely: version bump to 1.5.17
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/Manifest1
-rw-r--r--sci-libs/Shapely/Shapely-1.5.17.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Manifest b/sci-libs/Shapely/Manifest
index 6d0ebde8b8d9..989ab088434b 100644
--- a/sci-libs/Shapely/Manifest
+++ b/sci-libs/Shapely/Manifest
@@ -1,2 +1,3 @@
DIST Shapely-1.3.0.tar.gz 118863 SHA256 297df004aec27e38ed93987e93ff5f8187cd0299394fe8b0b9028566015a9bb5 SHA512 106f9773a5b00e7269a84c760f3a2b867c48139c48eebeecd524c8216d75c28daaf46eff45c118c1809999e33a317e9aca278a8d83605dc7273877a7ed3edd82 WHIRLPOOL ddf42cab233b0950a4a955070c5a2a7791a7f259ba857778689944c7799484f7c1aa710926c37c8c66deaae5ab4f03d79fa2f407e8e6d05238217b529e7b1b15
DIST Shapely-1.3.2.tar.gz 120179 SHA256 9f0de51c71373fcee4962f79f4813d67ea1e711f4394d7636c929a4019c5c2ff SHA512 23d65c5a7137726e05e0399dc49f05e5ad9b582d4adcdf30215f72ae75989e85daf30ea2a5010d6a5a086cb6bbb5b4599b5065080b845c833776812f6e46566d WHIRLPOOL 37836bd5597e485fe4ac8bb0994724fd7cde59bc2d57becd0e89547c0b561d147ff9bea3d99b1429c8a163538a7af7deb8416a4e5dfb8c9f7dff5322e81b2fb6
+DIST Shapely-1.5.17.tar.gz 180663 SHA256 31fee47d9208078a19f40a451c0c99c085d16343e66cbd0dd5af0af6f48cfc3a SHA512 eea241942ffbf377001445fab4017c9a2746d6bc0baa6c801a08ca95e608bbdaea7ad9568f00cbecdb559e634402bc6d213ebccb4074e59325e1cc4b3771626d WHIRLPOOL e28ffd196edc0bdfe2da86351410fb57bda774ecf7283c890f002261ab586351625a7d15aede0310de03175330fa522da693e8397c74857d606ed23a2de78547
diff --git a/sci-libs/Shapely/Shapely-1.5.17.ebuild b/sci-libs/Shapely/Shapely-1.5.17.ebuild
new file mode 100644
index 000000000000..fd3bc104c724
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.5.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_{1,2,3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}