summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-08 15:45:09 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-08 15:45:29 +0200
commiteb35b4541408d2362d28c24b4f907c1cf5a13e68 (patch)
tree94b012b60e375701a8b85cd0ec67dcebfe646f23 /sci-libs/alglib
parentdev-libs/fribidi: Version bump bug #559570. (diff)
downloadgentoo-eb35b4541408d2362d28c24b4f907c1cf5a13e68.tar.gz
gentoo-eb35b4541408d2362d28c24b4f907c1cf5a13e68.tar.bz2
gentoo-eb35b4541408d2362d28c24b4f907c1cf5a13e68.zip
sci-libs/alglib: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=559562 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/alglib')
-rw-r--r--sci-libs/alglib/Manifest1
-rw-r--r--sci-libs/alglib/alglib-3.10.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/alglib/Manifest b/sci-libs/alglib/Manifest
index 76f161451943..fd1554a6f809 100644
--- a/sci-libs/alglib/Manifest
+++ b/sci-libs/alglib/Manifest
@@ -1,2 +1,3 @@
+DIST alglib-3.10.0.cpp.gpl.tgz 1991101 SHA256 26a6aa966da5bba01da1bebddc0acb0a8fc579f07d53a2cbcfa5dfcaf612aaeb SHA512 f02b3db5ab8dee841f27186b6693997c4e6876e75310b0a31a04593dbcb41d300920404e32e7aecb39c8dd15e54cfee05b725caa27397a67b453f6e64cd1ef5e WHIRLPOOL c0092a82404b060de0bc01d3cba731eac0a5a8f17cea736b784091cadf672883438fdd9c3ab37efa764b8e57fb9a1d7ca3eb7a842b863c22d9961307041e5d66
DIST alglib-3.7.0.cpp.tgz 1518417 SHA256 62100afea6f3e54606031065d28b484ef82b3a96732265a23d8e0f17e34bd36c SHA512 055a292512eb6b5bdb667a2cfb8fda33237b17f1b900ba086e20a541af0f41bc85aef935c1357d780b45f3b1f2e6acddea23f19cdafa25a08f821aa391fec285 WHIRLPOOL 7dce3c5057c2b356b4f361304f2bfa6281671bb1f45204895864db0013ee18127f9cb4a64b311369debdf1adad4b4cb594514a7387adc6f9b9c21ccb4dc549f6
DIST alglib-3.8.2.cpp.tgz 1674260 SHA256 c02944558849c8b22f32f8dea03ebf3b77a0aab9aa2518927d25f6bfe7cb06a2 SHA512 3d7b6e3b5a29f25aee476bdd69e583d7504a2e06d390822b4aa2792eeb500e08c13477176be348a9dd560bad358e423465c9086f0c7c12f73dc88024364aed50 WHIRLPOOL 8ec5a51448c00241428f3b6c6191e31f94ee09dc1d94417178a59887edb8b4e8cfd561983bc4b31686971ad27c43e957aa7c1232e500000a0ea84e763f08ddcf
diff --git a/sci-libs/alglib/alglib-3.10.0.ebuild b/sci-libs/alglib/alglib-3.10.0.ebuild
new file mode 100644
index 000000000000..f413e0b30487
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="http://www.alglib.net/"
+SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.gpl.tgz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+S="${WORKDIR}"/cpp/
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt-3.8.2 CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( $(cmake-utils_use_build test) )
+ cmake-utils_src_configure
+}