summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-bcp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-bcp')
-rw-r--r--sci-libs/coinor-bcp/Manifest1
-rw-r--r--sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild59
-rw-r--r--sci-libs/coinor-bcp/metadata.xml13
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/coinor-bcp/Manifest b/sci-libs/coinor-bcp/Manifest
new file mode 100644
index 000000000000..e22e8cdb1040
--- /dev/null
+++ b/sci-libs/coinor-bcp/Manifest
@@ -0,0 +1 @@
+DIST Bcp-1.3.8.tgz 7086225 SHA256 db0079ba8adc16ca0a3065b385bf27352a27a9e031e8db52e96b4f883d4352f4 SHA512 c599cc60df37cab32cfbf24522efaababbdd2de6144c316390f5e0481863ffd6aec016f97188a610ae6aca8d4e5b1b8088a35bc81bd3448fadb1727a9e9663dd WHIRLPOOL 4bdc2a99bff6ed5b71a978feb224a1c2624b0519e0149b37fbd97c142c617502e46b8bbb9cf3516ebe4bf56c1c29e9cedf6bdcf52d08433fe2f20c7dfe5541b6
diff --git a/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
new file mode 100644
index 000000000000..13bc2678c6af
--- /dev/null
+++ b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Bcp
+
+DESCRIPTION="COIN-OR Branch-Cut-Price Framework"
+HOMEPAGE="https://projects.coin-or.org/Bcp/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-vol:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && newdoc doc/man.pdf manual.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-bcp/metadata.xml b/sci-libs/coinor-bcp/metadata.xml
new file mode 100644
index 000000000000..733700021f6b
--- /dev/null
+++ b/sci-libs/coinor-bcp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ BCP is a parallel framework for implementing branch, cut, and price
+ algorithms for solving mixed integer programs (MIPs). BCP provides
+ the user with an object-oriented framework that can be used to
+ develop an efficient problem class specific MIP solver without all
+ the implementational effort. involved with implementing a branch and
+ bound framework from scratch.
+</longdescription>
+</pkgmetadata>