summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-04 21:46:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-05 10:26:32 +0200
commitfca144ebd963f6e5a6144c499c419ecadfaae3f0 (patch)
tree014ac391c3a864fd13cea8ee4a5be47d60ef7765 /sci-libs/gdal/files/gdal-3.0.4-poppler-20.08.patch
parentmedia-sound/lilypond: fixed readme path in 9999 (diff)
downloadgentoo-fca144ebd963f6e5a6144c499c419ecadfaae3f0.tar.gz
gentoo-fca144ebd963f6e5a6144c499c419ecadfaae3f0.tar.bz2
gentoo-fca144ebd963f6e5a6144c499c419ecadfaae3f0.zip
sci-libs/gdal: Fix build against poppler-20.08
Thanks-to: PhobosK <phobosk@fastmail.fm> Closes: https://bugs.gentoo.org/735828 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/gdal/files/gdal-3.0.4-poppler-20.08.patch')
-rw-r--r--sci-libs/gdal/files/gdal-3.0.4-poppler-20.08.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-3.0.4-poppler-20.08.patch b/sci-libs/gdal/files/gdal-3.0.4-poppler-20.08.patch
new file mode 100644
index 000000000000..0fd8051c365c
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-3.0.4-poppler-20.08.patch
@@ -0,0 +1,42 @@
+From 2b863dbabdc2a7d724f9fdf3e6ff20a142b619f6 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Mon, 3 Aug 2020 14:52:25 +0200
+Subject: [PATCH] Unix build: fix detection of minor version number of Poppler
+ with the new YY.MM.X numbering scheme (fixes #2823) (#2825)
+
+Authored-by: @chris2553
+---
+ a/configure | 4 ++--
+ b/configure.ac | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure b/configure
+index 4d618db8149..69d46182a26 100755
+--- a/configure
++++ b/configure
+@@ -40824,8 +40824,8 @@ $as_echo "yes" >&6; }
+ fi
+ if test "$POPPLER_VERSION" != ""; then
+ HAVE_POPPLER=yes
+- POPPLER_MAJOR_VERSION=`expr $POPPLER_VERSION : '\([0-9]*\)'`
+- POPPLER_MINOR_VERSION=`expr $POPPLER_VERSION : '[0-9]*\.\([0-9]*\)'`
++ POPPLER_MAJOR_VERSION=`echo $POPPLER_VERSION | cut -d'.' -f1`
++ POPPLER_MINOR_VERSION=`echo $POPPLER_VERSION | cut -d'.' -f2 | sed -e 's/^0//'`
+ POPPLER_CFLAGS=`echo $POPPLER_CFLAGS $POPPLER_CFLAGS | sed "s/include\/poppler/include/"`
+ fi
+ else
+diff --git a/configure.ac b/configure.ac
+index 0f4124e6431..7f337e77c1d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4966,8 +4966,8 @@ if test "$with_poppler" != "no" -a "$with_poppler" != ""; then
+ [POPPLER_VERSION=`$PKG_CONFIG --modversion poppler`], [POPPLER_VERSION=])
+ if test "$POPPLER_VERSION" != ""; then
+ HAVE_POPPLER=yes
+- POPPLER_MAJOR_VERSION=`expr $POPPLER_VERSION : '\([[0-9]]*\)'`
+- POPPLER_MINOR_VERSION=`expr $POPPLER_VERSION : '[[0-9]]*\.\([[0-9]]*\)'`
++ POPPLER_MAJOR_VERSION=`echo $POPPLER_VERSION | cut -d'.' -f1`
++ POPPLER_MINOR_VERSION=`echo $POPPLER_VERSION | cut -d'.' -f2 | sed -e 's/^0//'`
+ POPPLER_CFLAGS=`echo $POPPLER_CFLAGS $POPPLER_CFLAGS | sed "s/include\/poppler/include/"`
+ fi
+ else