summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-05 20:02:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-05 20:02:02 +0200
commiteaf61075cf730121322d40b30273b4c9aed3161f (patch)
treee53429f7a588a65edff6ea7d312cf0eaffa6c7fb /sci-libs/getdata
parentsci-visualization/kst: Add missing DEPEND (diff)
downloadgentoo-eaf61075cf730121322d40b30273b4c9aed3161f.tar.gz
gentoo-eaf61075cf730121322d40b30273b4c9aed3161f.tar.bz2
gentoo-eaf61075cf730121322d40b30273b4c9aed3161f.zip
sci-libs/getdata: Run python-single-r1_pkg_setup conditionally
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sci-libs/getdata')
-rw-r--r--sci-libs/getdata/getdata-0.9.0-r1.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/sci-libs/getdata/getdata-0.9.0-r1.ebuild b/sci-libs/getdata/getdata-0.9.0-r1.ebuild
index 9bbc02d66ae9..d46c5d419c3a 100644
--- a/sci-libs/getdata/getdata-0.9.0-r1.ebuild
+++ b/sci-libs/getdata/getdata-0.9.0-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
FORTRAN_STANDARD="95"
FORTRAN_NEEDED=fortran
-
+PYTHON_COMPAT=( python2_7 )
inherit autotools eutils fortran-2 python-single-r1
DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
@@ -28,9 +26,11 @@ DEPEND="
python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}/${P}-remove-python-test.patch"
-)
+PATCHES=( "${FILESDIR}/${P}-remove-python-test.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
default
@@ -42,20 +42,20 @@ src_configure() {
--disable-idl \
--disable-matlab \
--disable-php \
- $(use_enable cxx cplusplus) \
- $(use_enable debug) \
- $(use_enable fortran) \
- $(use_enable fortran fortran95) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable static-libs static) \
--with-libz \
--without-libslim \
--without-libzzip \
$(use_with bzip2 libbz2) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable debug) \
$(use_with flac libFLAC) \
+ $(use_enable fortran) \
+ $(use_enable fortran fortran95) \
$(use_with lzma liblzma) \
- $(usex perl --with-perl-dir=vendor)
+ $(use_enable perl) \
+ $(usex perl --with-perl-dir=vendor) \
+ $(use_enable python) \
+ $(use_enable static-libs static)
}
src_install() {