summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-26 01:30:13 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-26 01:30:46 +0200
commita88d67480723e9230a4e20a555c1177a04644868 (patch)
treead404187890cf15c93adfa577efe674217a62fb6 /sci-libs/libcmatrix
parentsci-mathematics/rw: update François Bissey's email address in metadata.xml. (diff)
downloadgentoo-a88d67480723e9230a4e20a555c1177a04644868.tar.gz
gentoo-a88d67480723e9230a4e20a555c1177a04644868.tar.bz2
gentoo-a88d67480723e9230a4e20a555c1177a04644868.zip
sci-libs/libcmatrix: Allow for compiling with GCC 6
Gentoo-bug: 594680 * EAPI=6 * Make PATCHES -p1 compliant * Rename PATCHES to be in ${P}-xyz.patch format Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs/libcmatrix')
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.11.0-fix-c++14.patch40
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.11.0-shared.patch (renamed from sci-libs/libcmatrix/files/3.11.0-shared.patch)0
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.2.1-atlas.patch (renamed from sci-libs/libcmatrix/files/3.2.1-atlas.patch)0
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.4.patch (renamed from sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch)0
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.6.patch (renamed from sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch)0
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.7.patch (renamed from sci-libs/libcmatrix/files/3.2.1-gcc4.7.patch)0
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.2.1-minuit2.patch (renamed from sci-libs/libcmatrix/files/3.2.1-minuit2.patch)4
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.2.1-shared.patch (renamed from sci-libs/libcmatrix/files/3.2.1-shared.patch)0
-rw-r--r--sci-libs/libcmatrix/files/libcmatrix-3.9.0-atlas.patch (renamed from sci-libs/libcmatrix/files/3.9.0-atlas.patch)0
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild (renamed from sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild)40
10 files changed, 63 insertions, 21 deletions
diff --git a/sci-libs/libcmatrix/files/libcmatrix-3.11.0-fix-c++14.patch b/sci-libs/libcmatrix/files/libcmatrix-3.11.0-fix-c++14.patch
new file mode 100644
index 000000000000..74e49285dd04
--- /dev/null
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.11.0-fix-c++14.patch
@@ -0,0 +1,40 @@
+Fix building with C++14, which errors out due -Wnarrowing conversions.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594680
+
+--- a/include/lcm_ssecomplex.h
++++ b/include/lcm_ssecomplex.h
+@@ -151,7 +151,7 @@
+ {
+ static const union {
+ int i[4]; ssecomplex_t v;
+- } signbithigh = {{0,0,0,0x80000000}};
++ } signbithigh = {{0,0,0,(int)0x80000000}};
+ ssecomplex_t b_im = _mm_shuffle_pd(b,b,3); // Imag. part of b in both
+ const ssecomplex_t b_re = _mm_shuffle_pd(b,b,0); // Real part of b in both
+ const ssecomplex_t tmp=_mm_mul_pd(a,b_re);
+@@ -166,7 +166,7 @@
+ ssecomplex_t b_re = _mm_set1_pd(b);
+ static const union {
+ int i[4]; ssecomplex_t v;
+- } signbithigh = {{0,0,0,0x80000000}};
++ } signbithigh = {{0,0,0,(int)0x80000000}};
+ b_re = _mm_xor_pd(b_re, signbithigh.v); // Change sign of high
+ return complex(_mm_mul_pd(a.z_, b_re));
+ }
+@@ -184,14 +184,14 @@
+ inline complex operator- (const complex& a) {
+ static const union { // (signbit,signbit)
+ int i[4]; ssecomplex_t v;
+- } signbits = {{0,0x80000000,0,0x80000000}};
++ } signbits = {{0,(int)0x80000000,0,(int)0x80000000}};
+ return complex(_mm_xor_pd(a, signbits.v)); // Change sign of both elements
+ }
+
+ inline complex conj(const complex& a) {
+ static const union { // (signbit,signbit)
+ int i[4]; ssecomplex_t v;
+- } signbithigh = {{0,0,0,0x80000000}};
++ } signbithigh = {{0,0,0,(int)0x80000000}};
+ return complex(_mm_xor_pd(a.z_, signbithigh.v)); // Change sign of imag. part
+ }
+
diff --git a/sci-libs/libcmatrix/files/3.11.0-shared.patch b/sci-libs/libcmatrix/files/libcmatrix-3.11.0-shared.patch
index 6c5c3167619e..6c5c3167619e 100644
--- a/sci-libs/libcmatrix/files/3.11.0-shared.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.11.0-shared.patch
diff --git a/sci-libs/libcmatrix/files/3.2.1-atlas.patch b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-atlas.patch
index b10b41d4e389..b10b41d4e389 100644
--- a/sci-libs/libcmatrix/files/3.2.1-atlas.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-atlas.patch
diff --git a/sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.4.patch
index 24c1a89b48d0..24c1a89b48d0 100644
--- a/sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.4.patch
diff --git a/sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.6.patch
index b3d8c8d19996..b3d8c8d19996 100644
--- a/sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.6.patch
diff --git a/sci-libs/libcmatrix/files/3.2.1-gcc4.7.patch b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.7.patch
index 633c9d50cf94..633c9d50cf94 100644
--- a/sci-libs/libcmatrix/files/3.2.1-gcc4.7.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-gcc4.7.patch
diff --git a/sci-libs/libcmatrix/files/3.2.1-minuit2.patch b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-minuit2.patch
index 24dc5628b8f0..e7a6cec644bf 100644
--- a/sci-libs/libcmatrix/files/3.2.1-minuit2.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-minuit2.patch
@@ -1,5 +1,5 @@
---- configure-libraries.ac 2008-03-04 00:48:46.000000000 +0100
-+++ configure-libraries.ac.new 2009-03-19 18:22:21.000000000 +0100
+--- a/configure-libraries.ac
++++ b/configure-libraries.ac
@@ -14,8 +14,8 @@
fi
if test x$FOUNDMINUIT = xyes; then
diff --git a/sci-libs/libcmatrix/files/3.2.1-shared.patch b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-shared.patch
index 4e843027abde..4e843027abde 100644
--- a/sci-libs/libcmatrix/files/3.2.1-shared.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.2.1-shared.patch
diff --git a/sci-libs/libcmatrix/files/3.9.0-atlas.patch b/sci-libs/libcmatrix/files/libcmatrix-3.9.0-atlas.patch
index 329e794645eb..329e794645eb 100644
--- a/sci-libs/libcmatrix/files/3.9.0-atlas.patch
+++ b/sci-libs/libcmatrix/files/libcmatrix-3.9.0-atlas.patch
diff --git a/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild b/sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild
index e4b2694e46e2..139337417515 100644
--- a/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
+++ b/sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild
@@ -1,18 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
+inherit autotools
MY_P="${PN}${PV}_lite"
DESCRIPTION="lite version of pNMRsim"
HOMEPAGE="http://www.dur.ac.uk/paul.hodgkinson/pNMRsim/"
-#SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
LICENSE="all-rights-reserved"
@@ -25,19 +22,24 @@ DEPEND="${RDEPEND}"
RESTRICT=mirror
-S="${WORKDIR}"/${PN}R3
+S="${WORKDIR}/${PN}R3"
+DOCS=( CHANGES docs/cmatrix.pdf )
PATCHES=(
- "${FILESDIR}"/${PV}-shared.patch
- "${FILESDIR}"/3.2.1-minuit2.patch
- "${FILESDIR}"/3.2.1-gcc4.4.patch
- "${FILESDIR}"/3.2.1-gcc4.6.patch
- "${FILESDIR}"/3.2.1-gcc4.7.patch
- "${FILESDIR}"/3.9.0-atlas.patch
- "${FILESDIR}"/${P}-gcc5.2.patch
- )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
+ "${FILESDIR}/${PN}-3.11.0-shared.patch"
+ "${FILESDIR}/${PN}-3.2.1-minuit2.patch"
+ "${FILESDIR}/${PN}-3.2.1-gcc4.4.patch"
+ "${FILESDIR}/${PN}-3.2.1-gcc4.6.patch"
+ "${FILESDIR}/${PN}-3.2.1-gcc4.7.patch"
+ "${FILESDIR}/${PN}-3.9.0-atlas.patch"
+ "${FILESDIR}/${PN}-3.11.0-gcc5.2.patch"
+ "${FILESDIR}/${PN}-3.11.0-fix-c++14.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \
@@ -52,7 +54,7 @@ src_install() {
dolib.so lib/*.so*
insinto /usr/include/${PN}R3
- doins include/*
+ doins -r include/.
- dodoc CHANGES docs/*
+ einstalldocs
}