summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:21 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:44 +0100
commit9a41cc1078c6f843351db280f48f98c50bb1b11c (patch)
tree5fb54d3cea43e4abb9dd0041574c1ae8a1c864b2 /sci-libs/libdap
parentsci-libs/gdal: Always build in C++14 mode (diff)
downloadgentoo-9a41cc1078c6f843351db280f48f98c50bb1b11c.tar.gz
gentoo-9a41cc1078c6f843351db280f48f98c50bb1b11c.tar.bz2
gentoo-9a41cc1078c6f843351db280f48f98c50bb1b11c.zip
sci-libs/libdap: Always build in C++14 mode
Closes: https://bugs.gentoo.org/619144 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-libs/libdap')
-rw-r--r--sci-libs/libdap/libdap-3.18.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-libs/libdap/libdap-3.18.1.ebuild b/sci-libs/libdap/libdap-3.18.1.ebuild
index b0a4bfc02ba2..c0680c183d37 100644
--- a/sci-libs/libdap/libdap-3.18.1.ebuild
+++ b/sci-libs/libdap/libdap-3.18.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
HOMEPAGE="http://opendap.org/"
@@ -38,6 +38,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619144
+ append-cxxflags -std=c++14
+
econf \
--enable-shared \
$(use_enable static-libs static)