summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-12-28 12:25:00 +0100
committerPacho Ramos <pacho@gentoo.org>2016-12-28 12:25:47 +0100
commitc2ca03744553df978ac1c80ce6cdfb99e7f2a08b (patch)
tree6eb676c6beb38fdfc35722451e0168e2c70576a2 /sci-libs/netcdf
parentsci-libs/netcdf: hl support is needed for hdf5 versions that allow it to be d... (diff)
downloadgentoo-c2ca03744553df978ac1c80ce6cdfb99e7f2a08b.tar.gz
gentoo-c2ca03744553df978ac1c80ce6cdfb99e7f2a08b.tar.bz2
gentoo-c2ca03744553df978ac1c80ce6cdfb99e7f2a08b.zip
sci-libs/netcdf: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/Manifest1
-rw-r--r--sci-libs/netcdf/netcdf-4.4.1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/netcdf/Manifest b/sci-libs/netcdf/Manifest
index bed947ef9ec5..b56cba19885a 100644
--- a/sci-libs/netcdf/Manifest
+++ b/sci-libs/netcdf/Manifest
@@ -1,2 +1,3 @@
DIST netcdf-4.3.2.tar.gz 5013938 SHA256 57086b4383ce9232f05aad70761c2a6034b1a0c040260577d369b3bbfe6d248e SHA512 9cb9c761bf1e17a37601c37000fdc0bb654afcf111e5ac2fb7dcf037c6aa827e66beb29d5c661edc50ea3f84849f3dee387aab9e85ef81a9b6ca3f36e45debdd WHIRLPOOL 7fb0dd3324c3e8864729db1409a76feb84ef35298c0f79a4258f1cd30a70e90070d9a44275d064d8a4952c32671182f1bfe97d47f26cf921a625bbe7160f3249
DIST netcdf-4.4.0.tar.gz 17487357 SHA256 09b78b152d3fd373bee4b5738dc05c7b2f5315fe34aa2d94ee9256661119112f SHA512 c5cae15e86d11e6434a489bdac39ea498bdca2008ae6732a16603b32d79a9227a168a0fa0174c6d55ced0c92d9b644f60db4d946f695731161572abd6b778fa1 WHIRLPOOL cdbf02533cd3ebaad563d28a853ec43f0297e4a4be2ced0aea2f44aa07768846a1dba98199c961d5674996f96f931a7b39df584836fd3451530e37a73277de2f
+DIST netcdf-4.4.1.1.tar.gz 17670828 SHA256 7f040a0542ed3f6d27f3002b074e509614e18d6c515b2005d1537fec01b24909 SHA512 ee23f37d7b40e7b9a115d29bc038c7c654d50dedfcad62617b8dee3efa4668305e6a0656ba655770727ff46f4b6d742869c719267eca3392c94e2488eb902da7 WHIRLPOOL 9cb996847441a4f0a865890637f1a5f54ff3a914918f465edd31811c32218c78fdd27017c6bd50d5b09f95a76ccc0421c5e4801c75c8a6689b390aa9fe6b08a9
diff --git a/sci-libs/netcdf/netcdf-4.4.1.1.ebuild b/sci-libs/netcdf/netcdf-4.4.1.1.ebuild
new file mode 100644
index 000000000000..a2b07fc2c3af
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.4.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/11"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+dap examples hdf +hdf5 mpi static-libs szip test tools"
+
+RDEPEND="
+ dap? ( net-misc/curl:0= )
+ hdf? ( sci-libs/hdf:0= sci-libs/hdf5:0= )
+ hdf5? ( sci-libs/hdf5:0=[hl(+),mpi=,szip=,zlib] )"
+DEPEND="${RDEPEND}"
+# doc generation is missing many doxygen files in tar ball
+# doc? ( app-doc/doxygen[dot] )"
+
+REQUIRED_USE="test? ( tools ) szip? ( hdf5 ) mpi? ( hdf5 )"
+
+S="${WORKDIR}/${PN}-c-${PV}"
+
+src_configure() {
+ local myconf
+ if use mpi; then
+ export CC=mpicc
+ myconf="--enable-parallel"
+ use test && myconf+=" --enable-parallel-tests"
+ fi
+ econf "${myconf}" \
+ --disable-examples \
+ --disable-dap-remote-tests \
+ $(use_enable dap) \
+ $(use_enable hdf hdf4) \
+ $(use_enable hdf5 netcdf-4) \
+ $(use_enable static-libs static) \
+ $(use_enable tools utilities)
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ prune_libtool_files
+}