summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2018-12-25 19:58:57 -0800
committerAmy Liffey <amynka@gentoo.org>2019-01-02 19:46:53 +0100
commitb8794f90839cb9074493a782dfd2e6f8e70e6c37 (patch)
tree3cd4ade74f27cbf4ef52ef5a02c24217b870712e /sci-libs/oce
parentdev-ada/gps: Stable (diff)
downloadgentoo-b8794f90839cb9074493a782dfd2e6f8e70e6c37.tar.gz
gentoo-b8794f90839cb9074493a782dfd2e6f8e70e6c37.tar.bz2
gentoo-b8794f90839cb9074493a782dfd2e6f8e70e6c37.zip
sci-libs/oce: Fix failing tests
Closes: https://bugs.gentoo.org/665596 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/10694 Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.12
Diffstat (limited to 'sci-libs/oce')
-rw-r--r--sci-libs/oce/files/oce-0.18.3-test-fix.patch13
-rw-r--r--sci-libs/oce/oce-0.18.3-r1.ebuild (renamed from sci-libs/oce/oce-0.18.3.ebuild)4
2 files changed, 16 insertions, 1 deletions
diff --git a/sci-libs/oce/files/oce-0.18.3-test-fix.patch b/sci-libs/oce/files/oce-0.18.3-test-fix.patch
new file mode 100644
index 000000000000..bec55d9d36b4
--- /dev/null
+++ b/sci-libs/oce/files/oce-0.18.3-test-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/test/OCAFExport_test/CMakeLists.txt b/test/OCAFExport_test/CMakeLists.txt
+index f81798a3a4..8d9f6ad86c 100644
+--- a/test/OCAFExport_test/CMakeLists.txt
++++ b/test/OCAFExport_test/CMakeLists.txt
+@@ -5,6 +5,6 @@ if (OCE_OCAF AND NOT OCE_DISABLE_X11)
+ file(TO_NATIVE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/../../src/StdResource" BuildPluginDir)
+ # Semi-colon is a delimiter in SET_TESTS_PROPERTIES and have to be escaped
+ string(REPLACE ";" "\\;" BuildPluginDir "${BuildPluginDir}")
+- set_tests_properties(OCAFExportTestSuite.testExportAscii PROPERTIES ENVIRONMENT "CSF_PluginDefaults=${BuildPluginDir};CSF_StandardDefaults=${BuildPluginDir}")
+- set_tests_properties(OCAFExportTestSuite.testExportNonAscii PROPERTIES ENVIRONMENT "CSF_PluginDefaults=${BuildPluginDir};CSF_StandardDefaults=${BuildPluginDir}")
++ set_tests_properties(OCAFExportTestSuite.testExportAscii PROPERTIES ENVIRONMENT "CSF_PluginDefaults=${BuildPluginDir};CSF_StandardDefaults=${BuildPluginDir};LD_LIBRARY_PATH=$ENV{LD_LIBRARY_PATH}:${LIBRARY_OUTPUT_PATH}")
++ set_tests_properties(OCAFExportTestSuite.testExportNonAscii PROPERTIES ENVIRONMENT "CSF_PluginDefaults=${BuildPluginDir};CSF_StandardDefaults=${BuildPluginDir};LD_LIBRARY_PATH=$ENV{LD_LIBRARY_PATH}:${LIBRARY_OUTPUT_PATH}")
+ endif ()
diff --git a/sci-libs/oce/oce-0.18.3.ebuild b/sci-libs/oce/oce-0.18.3-r1.ebuild
index 69c85c7057f2..0835a64d2bf5 100644
--- a/sci-libs/oce/oce-0.18.3.ebuild
+++ b/sci-libs/oce/oce-0.18.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,6 +37,8 @@ RDEPEND="${DEPEND}"
CHECKREQS_MEMORY="256M"
CHECKREQS_DISK_BUILD="3584M"
+PATCHES=( "${FILESDIR}"/"${P}-test-fix.patch" )
+
pkg_setup() {
check-reqs_pkg_setup
}