summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-14 11:27:43 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-14 11:30:22 -0600
commit2fbbafef94953e4a52c7ff37f8a517971ae16072 (patch)
treed2ce261ccd57c7b6cc531d372d290f6acf19a6e4 /sci-libs/votca-tools
parentsci-chemistry/votca-csg: fix cmake-3.4 build (bug #588834) (diff)
downloadgentoo-2fbbafef94953e4a52c7ff37f8a517971ae16072.tar.gz
gentoo-2fbbafef94953e4a52c7ff37f8a517971ae16072.tar.bz2
gentoo-2fbbafef94953e4a52c7ff37f8a517971ae16072.zip
sci-libs/votca-tools: import live ebuild from sci
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
new file mode 100644
index 000000000000..34b0cd25a639
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils eutils multilib
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc +fftw +gsl sqlite"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ fftw? ( sci-libs/fftw:3.0 )
+ gsl? ( sci-libs/gsl )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.7.6.1[dot] )
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=( NOTICE )
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_GSL=$(usex gsl)
+ -DWITH_FFTW=$(usex fftw)
+ -DWITH_SQLITE3=$(usex sqlite)
+ -DWITH_RC_FILES=OFF
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ cmake-utils_src_make html
+ dodoc -r share/doc/html
+ fi
+}