summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/vtkdata
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/vtkdata')
-rw-r--r--sci-libs/vtkdata/Manifest2
-rw-r--r--sci-libs/vtkdata/metadata.xml8
-rw-r--r--sci-libs/vtkdata/vtkdata-6.0.0.ebuild27
-rw-r--r--sci-libs/vtkdata/vtkdata-6.1.0.ebuild27
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-libs/vtkdata/Manifest b/sci-libs/vtkdata/Manifest
new file mode 100644
index 000000000000..56ad96ee0fe4
--- /dev/null
+++ b/sci-libs/vtkdata/Manifest
@@ -0,0 +1,2 @@
+DIST VTKData-6.1.0.tar.gz 94452190 SHA256 aba27ac05d721e36b9424131f1d0f673448f2b31aac34e9e74590fdf208ad0c7 SHA512 4e23cc3de3b81a852458849f2bd4dfe2e84e9df4f77f5f0d4ac249b04a7f74144a483a91876bd748bb90685d1943071e9b36fce8dd618376621bc37e63365e65 WHIRLPOOL 1ee803055e3bbf0c8150807a77efce81406c8a512c40644c5ccc35279cb1098bb8f0382b5f2bb01f483c8a38a4e81ee70ed39145c52b4375a0545919faee2a28
+DIST vtkdata-6.0.0.tar.gz 99106820 SHA256 d5cb638804cc09838e05876f1701d2e9cf7aa3a5c63885da7c2ddf52b2fbb04d SHA512 b76eb8389047de1b74c585b8a3064d499758886f8e44063cb0d73fdc29b1a7cfbb1926bca869ccfbfaada3cffbb74a78a01fa081fd230002af7c4d79aa8a90af WHIRLPOOL 213a9ad270cf528cdfd9b601eaceba185d8388f629023fcd59603324539251c55c34685943122c07efd4e8b54217686399d9ec9d4e6e2780f33fcb510b148dc6
diff --git a/sci-libs/vtkdata/metadata.xml b/sci-libs/vtkdata/metadata.xml
new file mode 100644
index 000000000000..5ef07a39e7e1
--- /dev/null
+++ b/sci-libs/vtkdata/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/vtkdata/vtkdata-6.0.0.ebuild b/sci-libs/vtkdata/vtkdata-6.0.0.ebuild
new file mode 100644
index 000000000000..d72f22fbdb53
--- /dev/null
+++ b/sci-libs/vtkdata/vtkdata-6.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Example data file for VTK"
+HOMEPAGE="http://www.vtk.org"
+SRC_URI="http://www.vtk.org/files/release/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+RDEPEND="!<sci-libs/vtk-6"
+
+S="${WORKDIR}"/VTKDATA${PV}
+
+src_install() {
+ insinto /usr/share/vtk/data
+ doins -r *
+}
diff --git a/sci-libs/vtkdata/vtkdata-6.1.0.ebuild b/sci-libs/vtkdata/vtkdata-6.1.0.ebuild
new file mode 100644
index 000000000000..62f885eab3ca
--- /dev/null
+++ b/sci-libs/vtkdata/vtkdata-6.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Example data file for VTK"
+HOMEPAGE="http://www.vtk.org"
+SRC_URI="http://www.vtk.org/files/release/$(get_version_component_range 1-2)/VTKData-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+RDEPEND="!<sci-libs/vtk-6"
+
+S="${WORKDIR}"/VTK-${PV}
+
+src_install() {
+ insinto /usr/share/vtk/data
+ doins -r .ExternalData
+}