summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-02-19 00:00:10 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-02-19 00:03:45 +0300
commit6f2625267306589c6d19cad67132ea280e8dfb57 (patch)
treed8b29e3fd47193f4b373e1ab1dc89205ca6d504b /sci-libs
parentnet-mail/qmail-autoresponder: Revbump for EAPI and dependency change (diff)
downloadgentoo-6f2625267306589c6d19cad67132ea280e8dfb57.tar.gz
gentoo-6f2625267306589c6d19cad67132ea280e8dfb57.tar.bz2
gentoo-6f2625267306589c6d19cad67132ea280e8dfb57.zip
sci-libs/lmfit: Version bump
Closes: https://bugs.gentoo.org/678314 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lmfit/Manifest1
-rw-r--r--sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch85
-rw-r--r--sci-libs/lmfit/lmfit-8.2.2.ebuild25
3 files changed, 111 insertions, 0 deletions
diff --git a/sci-libs/lmfit/Manifest b/sci-libs/lmfit/Manifest
index 1514817e48a5..acb200a85141 100644
--- a/sci-libs/lmfit/Manifest
+++ b/sci-libs/lmfit/Manifest
@@ -2,3 +2,4 @@ DIST lmfit-5.1.tgz 345077 BLAKE2B df27621745601ffacd2110b28f3e3ea2b06d4c8c3c8fad
DIST lmfit-6.4.tgz 388809 BLAKE2B 48aa619642ac3fd009ec6a8f8b44ee4c800fc3f33e2603b557218cdf37c789159dc3947a648d560b9e2dd7fef08a6644fd25ac61505859dc3b1d151eeea58c27 SHA512 2bd0f24dd4638345b8b1ce6803ddcf45ca3ef888eb285e99f9f158c2e30b0f96016d9d84a112cdbf28f2ba98470e54fe773416179a65264426043c9a5186757d
DIST lmfit-7.0.tgz 37950 BLAKE2B a509110f70e7e863d1172b8d91f7439763f0434702f265751e9955494f4982b4c17f0baaa080af86e5cae7f535555e27b98b45ba6a529061d107e53bdb9fd698 SHA512 78f479786c6e5c417781c6d629f5a517335fac70df049fafdefd511485da4e542c988d69c998f96eaab4306160de4bb09a631ca6ffff74bba70c51428d734fc3
DIST lmfit-8.0.tgz 42833 BLAKE2B d2ad9f5cd35997c8ce6827148e9ca748f3d14044f515a927442e9e5f57508cdfb729cd7172987a0e94284d7e93f7aafc0cb572137f201994c8d3ad9a9fb64c9b SHA512 3b4e4af6c70269f8752428d416e014d4e69df3f73b25e9ba16dd07afc03598a1dca08050cecba29a3b2651e003e703ba4412716100b1bb55b1830f74f16da676
+DIST lmfit-8.2.2.tgz 31970 BLAKE2B 67eebc0e58d3d78057afcd84f35adcfea783c8501a5f8934dd07c38eb2419b1c43bedd3401a830a993005913138bdf8d1dc73c2142983b9f881f0db9bec06b93 SHA512 5835dce914027429cb36765543cf6b872e4ef1acd8feaeca281f9edf286fda89db78fbc0713dcfea4e4f2fe55a1b05317e6428980060bc3acce579ef1fa0c271
diff --git a/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch b/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch
new file mode 100644
index 000000000000..258f70a533d4
--- /dev/null
+++ b/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch
@@ -0,0 +1,85 @@
+From 72dae8c23604288331c9a7f03f60ec792a384121 Mon Sep 17 00:00:00 2001
+From: christoph junghans <junghans@votca.org>
+Date: Mon, 22 Oct 2018 21:00:00 -0600
+Subject: [PATCH] cmake: minor distribution tweaks
+
+- use gnuinstalldirs to allow to configure install dirs
+- allow to disable injecting c flags
+
+signed-off-by: christoph junghans <junghans@votca.org>
+Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
+---
+ CMakeLists.txt | 10 +++++++---
+ lib/CMakeLists.txt | 4 ++--
+ man/CMakeLists.txt | 4 ++--
+ 3 files changed, 11 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dbb571e..279f06a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,7 +4,7 @@ cmake_policy(SET CMP0048 NEW)
+ list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
+ include(PreventInSourceBuilds)
+
+-project(lmfit VERSION 8.2.1 LANGUAGES C)
++project(lmfit VERSION 8.2.2 LANGUAGES C)
+
+ # --- Declare project-wide user flags, and set default values ---
+ option(FITTEST "Build with FitTest" OFF)
+@@ -23,12 +23,16 @@ else()
+ endif()
+
+ include(CTest)
++include(GNUInstallDirs)
+
+-set(destination ${CMAKE_INSTALL_PREFIX})
++option(INJECT_C_FLAGS "Inject a bunch of useful c flags" ON)
++if (INJECT_C_FLAGS)
++ set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas")
++endif()
+
+ configure_file("lmfit.pc.in" "lmfit.pc" @ONLY)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/lmfit.pc"
+- DESTINATION "${destination}/lib/pkgconfig/")
++ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
+
+ add_subdirectory(lib)
+ add_subdirectory(demo)
+diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
+index a266f4e..e071a3c 100644
+--- a/lib/CMakeLists.txt
++++ b/lib/CMakeLists.txt
+@@ -18,9 +18,9 @@ link_libm(${library_name})
+
+ install(
+ TARGETS ${library_name} LIBRARY
+- DESTINATION ${destination}/lib
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT Libraries)
+ install(
+ FILES ${inc_files}
+- DESTINATION ${destination}/include
++ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ COMPONENT Headers)
+diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
+index d4595fd..5505713 100644
+--- a/man/CMakeLists.txt
++++ b/man/CMakeLists.txt
+@@ -15,11 +15,11 @@ function(one_page pname section)
+ )
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${pname}.${section}
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/man/man${section}"
++ DESTINATION "${CMAKE_INSTALL_MANDIR}/man${section}"
+ )
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${pname}.html
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/doc/lmfit/html"
++ DESTINATION "${CMAKE_INSTALL_DOCDIR}-${CMAKE_PROJECT_VERSION}/html"
+ )
+ endfunction()
+
+--
+2.20.1
+
diff --git a/sci-libs/lmfit/lmfit-8.2.2.ebuild b/sci-libs/lmfit/lmfit-8.2.2.ebuild
new file mode 100644
index 000000000000..6d1f6b2e4b60
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-8.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINJECT_C_FLAGS=OFF
+ )
+
+ cmake-utils_src_configure
+}