summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-21 18:31:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-22 00:02:49 +0000
commita4a87f6c2c7be01c22c06c0030799ae3934bc425 (patch)
tree25943f3ab317c394cdf16bb42ea30f2c22d72818 /sci-libs
parentdev-python/naima: initial import (diff)
downloadgentoo-a4a87f6c2c7be01c22c06c0030799ae3934bc425.tar.gz
gentoo-a4a87f6c2c7be01c22c06c0030799ae3934bc425.tar.bz2
gentoo-a4a87f6c2c7be01c22c06c0030799ae3934bc425.zip
sci-libs/idlcoyote: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/idlcoyote/Manifest1
-rw-r--r--sci-libs/idlcoyote/files/idlcoyote-cgloadct.patch77
-rw-r--r--sci-libs/idlcoyote/files/idlcoyote-gdl-fixes.patch13
-rw-r--r--sci-libs/idlcoyote/idlcoyote-20160321.ebuild32
-rw-r--r--sci-libs/idlcoyote/metadata.xml14
5 files changed, 137 insertions, 0 deletions
diff --git a/sci-libs/idlcoyote/Manifest b/sci-libs/idlcoyote/Manifest
new file mode 100644
index 000000000000..b065d17e2362
--- /dev/null
+++ b/sci-libs/idlcoyote/Manifest
@@ -0,0 +1 @@
+DIST idlcoyote-20160321.zip 1360470 SHA256 35a7735df44dbad466051aa18890405e0d5a8abba4bf82dd8baafc104ca5fb56 SHA512 e4cd163b684d44bfacdd56895441ddddc7ab06360c31a94fb5334ba64ab3fb42bdf52ee359585d8766ae9d04d3f9e140e0ee6f507290f3dd01f5728384229ddd WHIRLPOOL 309e69fae6d18640cb3bcd886091875427527939692e68417465d815827c18a8e58a1983211c9c149f84f6cfea9f9fc8273b5cb101ad6fbb30a3984cf90f1c09
diff --git a/sci-libs/idlcoyote/files/idlcoyote-cgloadct.patch b/sci-libs/idlcoyote/files/idlcoyote-cgloadct.patch
new file mode 100644
index 000000000000..ec2afd09882e
--- /dev/null
+++ b/sci-libs/idlcoyote/files/idlcoyote-cgloadct.patch
@@ -0,0 +1,77 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Use loadct in cgloadct if no file is specified.
+ GDL does not shipt with a color table "colors1.tbl", so in the case
+ that no file name is specified, fall back to loadct instead of trying to
+ load this file.
+--- a/cgloadct.pro
++++ b/cgloadct.pro
+@@ -86,8 +86,8 @@
+ ; If this keyword is set to a named variable, the color table is returned as an
+ ; [NCOLORS,3] array and no colors are loaded in the display.
+ ; filename: in, optional, type='string'
+-; The name of a color table file to open. By default colors1.tbl in the IDL
+-; resource directory.
++; The name of a color table file to open. By default the gdl standard
++;color table
+ ; get_names: out, optional, type='string'
+ ; If set to a named variable, the names of the color tables are returned
+ ; and no colors are loaded in the display. Note that RGB_TABLE cannot be
+@@ -192,9 +192,8 @@
+ Catch, /CANCEL
+ Help, LAST_MESSAGE=1, OUTPUT=traceback
+ Help, Calls=callStack
+- callingRoutine = (StrSplit(StrCompress(callStack[1])," ", /Extract))[0]
+- Print,''
+- Print, 'Traceback Report from ' + StrUpCase(callingRoutine) + ':'
++ Print,''+callStack
++ Print, 'Traceback Report from:'
+ Print, ''
+ FOR j=0,N_Elements(traceback)-1 DO Print, " " + traceback[j]
+ void = Dialog_Message(traceback[0], /Error, TITLE='Trapped Error')
+@@ -236,11 +235,9 @@
+ IF N_Elements(clip) EQ 0 THEN clip = [0,255]
+ IF N_Elements(clip) EQ 1 THEN clip = [clip, 255]
+ clip = 0 > clip < 255
+- IF N_Elements(file) EQ 0 THEN file = Filepath('colors1.tbl', SUBDIRECTORY=['resource', 'colors'])
+-
+ ; Try to locate the brewer file.
+ IF Keyword_Set(brewer) THEN BEGIN
+- brewerfilepath = Filepath( ROOT_DIR=cgSourceDir(), 'fsc_brewer.tbl')
++ brewerfilepath = Filepath( ROOT_DIR='/usr/share/gnudatalanguage/coyote', 'fsc_brewer.tbl')
+ brewerFile = File_Search(brewerfilepath, Count=count)
+ IF count EQ 0 THEN BEGIN
+ Message, 'Cannot find the Brewer color table file "fsc_brewer.tbl."' + $
+@@ -257,6 +254,14 @@
+ IF N_Elements(ncolors) EQ 0 THEN ncolors = !D.TABLE_SIZE - bottom
+ reverse = KEYWORD_SET(reverse)
+
++ IF N_Elements(file) EQ 0 THEN BEGIN
++ loadct, table, get_names=get_names, ncolors=ncolors, bottom=bottom, $
++ silent=silent, rgb_table=ltable
++ len = N_Elements(ltable)/3
++ r = ltable[0:len-1]
++ g = ltable[len:2*len-1]
++ b = ltable[2*len:3*len-1]
++ ENDIF ELSE BEGIN
+ ; Open and read the color table files.
+ OPENR, lun, file, /GET_LUN
+ ntables = 0B
+@@ -284,6 +289,7 @@
+
+ ; Close the file.
+ FREE_LUN, lun
++ ENDELSE
+
+ ; Clip the colors.
+ r = r[clip[0]:clip[1]]
+--- a/xcolors.pro
++++ b/xcolors.pro
+@@ -838,7 +838,7 @@
+ END
+
+ 'BREWER': BEGIN
+- info.file = cgFindPathTo('fsc_brewer.tbl')
++ info.file = '/usr/share/gnudatalanguage/fsc_brewer.tbl'
+ info.brewer = 1
+ END
+ ENDCASE
diff --git a/sci-libs/idlcoyote/files/idlcoyote-gdl-fixes.patch b/sci-libs/idlcoyote/files/idlcoyote-gdl-fixes.patch
new file mode 100644
index 000000000000..ba0ff2cd786d
--- /dev/null
+++ b/sci-libs/idlcoyote/files/idlcoyote-gdl-fixes.patch
@@ -0,0 +1,13 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Various small patches to fix things under GDL
+--- a/convert_to_type.pro
++++ b/convert_to_type.pro
+@@ -122,7 +122,7 @@
+ (type EQ 8): Message, 'Unable to convert input to STRUCTURE data type.'
+ (type EQ 10): Message, 'Unable to convert input to POINTER data type.'
+ (type EQ 11): Message, 'Unable to convert input to OBJECT data type.'
+- (type GT 15): Message, 'Unable to convert undefined data type: ', StrTrim(theType) + '.'
++ (type GT 15): Message, 'Unable to convert undefined data type: ' + StrTrim(theType) + '.'
+ ELSE:
+ ENDCASE
+ ENDELSE
diff --git a/sci-libs/idlcoyote/idlcoyote-20160321.ebuild b/sci-libs/idlcoyote/idlcoyote-20160321.ebuild
new file mode 100644
index 000000000000..2bcbf088ea3e
--- /dev/null
+++ b/sci-libs/idlcoyote/idlcoyote-20160321.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="GDL library from D. Fannings IDL courses"
+HOMEPAGE="http://www.idlcoyote.com/"
+SRC_URI="http://www.idlcoyote.com/programs/zip_files/coyoteprograms.zip -> ${P}.zip"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/gdl"
+
+S="${WORKDIR}/coyote"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-cgloadct.patch"
+ "${FILESDIR}/${PN}-gdl-fixes.patch"
+)
+
+src_install() {
+ dodoc README.txt
+ newdoc public/README.txt README-public.txt
+ rm README.txt public/README.txt || die
+ insinto /usr/share/gnudatalanguage/coyote
+ doins -r *
+}
diff --git a/sci-libs/idlcoyote/metadata.xml b/sci-libs/idlcoyote/metadata.xml
new file mode 100644
index 000000000000..23592779f7fb
--- /dev/null
+++ b/sci-libs/idlcoyote/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ The Coyote Library evolved from work David Fanning was doing teaching
+ IDL courses and answering IDL questions on the IDL newsgroup. It is
+ meant to be a well-documented library that demonstrates how to write
+ solid IDL/GDL programs that are easy to maintain and extend.
+</longdescription>
+</pkgmetadata>