summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 13:01:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 13:02:23 +0200
commitdbbdef9cc7ea934131d057bfd5e885e6182a6f3f (patch)
treed72db87780b44da7065a66ae6aafa4fac7c517f3 /sci-libs
parentsci-libs/itpp: Add missing || die (diff)
downloadgentoo-dbbdef9cc7ea934131d057bfd5e885e6182a6f3f.tar.gz
gentoo-dbbdef9cc7ea934131d057bfd5e885e6182a6f3f.tar.bz2
gentoo-dbbdef9cc7ea934131d057bfd5e885e6182a6f3f.zip
sci-libs/itpp: EAPI-6 bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sci-libs/itpp/itpp-4.3.1-r1.ebuild b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
index 53cdbee6564e..8d522b501ed5 100644
--- a/sci-libs/itpp/itpp-4.3.1-r1.ebuild
+++ b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils multilib
+inherit cmake-utils
DESCRIPTION="C++ library of mathematical, signal processing and communication"
HOMEPAGE="http://itpp.sourceforge.net/"
@@ -15,12 +15,17 @@ KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="doc"
RDEPEND="
+ sci-libs/fftw:3.0=
virtual/blas
virtual/lapack
- >=sci-libs/fftw-3"
+"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? ( app-doc/doxygen virtual/latex-base )"
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )
+"
DOCS=( ChangeLog NEWS AUTHORS README )
@@ -48,7 +53,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBLA_VENDOR=Generic
- $(cmake-utils_use doc HTML_DOCS)
+ -DHTML_DOCS=$(usex doc)
)
cmake-utils_src_configure
}