summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-10-14 08:58:53 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-10-14 08:58:53 +0200
commitebe231de790ad2672cfb20daaaa50d2789fb5e11 (patch)
tree68e1a0560716e91b26237a79d7e10aa28b888bc0 /sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
parentnet-libs/gnutls: fix metadata.xml spaces (diff)
downloadgentoo-ebe231de790ad2672cfb20daaaa50d2789fb5e11.tar.gz
gentoo-ebe231de790ad2672cfb20daaaa50d2789fb5e11.tar.bz2
gentoo-ebe231de790ad2672cfb20daaaa50d2789fb5e11.zip
sci-mathematics/alt-ergo: Adding alt-ergo 1.30
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild b/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
new file mode 100644
index 000000000000..46560c627430
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="http://alt-ergo.ocamlpro.com"
+SRC_URI="https://alt-ergo.ocamlpro.com/http/${P}/${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples gtk +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
+ dev-ml/zarith
+ gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
+ dev-ml/camlzip
+ dev-ml/ocplib-simplex"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES INSTALL.md README.md )
+
+src_compile() {
+ emake
+ use gtk && emake gui
+}
+
+src_install() {
+ default
+ use gtk && emake DESTDIR="${D}" install-gui
+ insinto /usr/share/doc/${PF}
+ use examples && doins -r examples
+}