summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-02-02 18:30:34 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-02-02 18:30:34 +0700
commit160e3b15690cd14bfa268eced01a75f3a8062463 (patch)
tree6fdd3eedccaa777dbcb9b86e2dd0831e26cdf27c /sci-mathematics/arb
parentdune.eclass: enhance build and test logs (diff)
downloadgentoo-160e3b15690cd14bfa268eced01a75f3a8062463.tar.gz
gentoo-160e3b15690cd14bfa268eced01a75f3a8062463.tar.bz2
gentoo-160e3b15690cd14bfa268eced01a75f3a8062463.zip
sci-mathematics/arb: bump to 2.22.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/arb')
-rw-r--r--sci-mathematics/arb/Manifest1
-rw-r--r--sci-mathematics/arb/arb-2.22.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index 35013f249603..0e420ec7abec 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1,2 +1,3 @@
DIST arb-2.19.0.tar.gz 1606463 BLAKE2B 85d832113ae42737a460198cbf485f825a9435963a888c0d0ab87b7ed7277d158480b573fd8ace42484dd4767bf4f1a372f637cfff01f18c105fd2b62d0d019e SHA512 199d1a26edd01e3b30f7aef69a9ae29456e3db384037744a1e073007ddb93a248873dfe83f3e48f9de58a9d17ebd7dc9a22a058f4adf766599d01d7eb17db204
DIST arb-2.21.0.tar.gz 1842021 BLAKE2B 1ab3c4d18eb1918eaee9ea9aff68d82fc33a136ff5612e5173bf0cc29e5753f2c002256d68ae7983b5677d5082ab6849c68755e7544cee24144ca4e84e4d8411 SHA512 e441f8325d3095f1d568ebf9018520aedb25b6a066678e870942efcc8ac005dbf10cdffe42bc4fdbce3ba3ac397241c1d92fb54556e444243bd56dd3d5d72664
+DIST arb-2.22.1.tar.gz 1906319 BLAKE2B a302fe35ce5820f8cd7f98831906e9a114e120e6cfd24f42c9d76c9cb67cb232bf9b6b369801d201536552daa8cb7310bbabb7f8924a67d416ada4d37d1fcee1 SHA512 e5092b1b3f828d21a5e18722004aac5af4268b4bdce1d2a7e858485ca59ed77b32661678e229e7a44ebd29678aebe9e6b591f0dd3e1a9751460fc5d72980d0c4
diff --git a/sci-mathematics/arb/arb-2.22.1.ebuild b/sci-mathematics/arb/arb-2.22.1.ebuild
new file mode 100644
index 000000000000..0c54365c8935
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.22.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=Release
+inherit cmake
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ sci-mathematics/flint:="
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake_src_configure
+}