summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-11-16 08:59:54 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-11-16 09:00:10 -0500
commit5dc188ddd7e5ffe6b5afb9154531484a6dd187d1 (patch)
treeb17f27b72f97b5c59fded4dcca39fbfb73e63930 /sci-mathematics/dunshire
parentx11-misc/nitrogen: Fix sandbox violation (bug #599720 by Toralf Förster). (diff)
downloadgentoo-5dc188ddd7e5ffe6b5afb9154531484a6dd187d1.tar.gz
gentoo-5dc188ddd7e5ffe6b5afb9154531484a6dd187d1.tar.bz2
gentoo-5dc188ddd7e5ffe6b5afb9154531484a6dd187d1.zip
sci-mathematics/dunshire: new package to solve linear games over cones.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics/dunshire')
-rw-r--r--sci-mathematics/dunshire/Manifest1
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1.ebuild32
-rw-r--r--sci-mathematics/dunshire/metadata.xml12
3 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/dunshire/Manifest b/sci-mathematics/dunshire/Manifest
new file mode 100644
index 000000000000..17b993e73293
--- /dev/null
+++ b/sci-mathematics/dunshire/Manifest
@@ -0,0 +1 @@
+DIST dunshire-0.1.1.tar.gz 300878 SHA256 93ff5659d96687fa2f5f1d1c7432bb03187ad3ec8357a30856aec4bf353bf71c SHA512 5cdf8125d7fc1f76a483009392360e9e9088f9b58ca3f123d14e366421e831e4e7c8e17d367ba0430fb3cd61873cae7a004c903ff5417bfc9adecb7831681081 WHIRLPOOL 4fec60b47ddd228d428fd7e7def122e4757b2e19a5ae565d47b9b70480c1d9d80d8d583aaef9cf81caedc6d23655293e201f6ce4487e18beca5cef8b3b3edd5a
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
new file mode 100644
index 000000000000..0cc06cb07733
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="http://michael.orlitzky.com/code/dunshire"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ local DOCS=( doc/README.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/sci-mathematics/dunshire/metadata.xml b/sci-mathematics/dunshire/metadata.xml
new file mode 100644
index 000000000000..cf8612d137ba
--- /dev/null
+++ b/sci-mathematics/dunshire/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">dunshire</remote-id>
+ </upstream>
+</pkgmetadata>