summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2016-12-02 12:06:31 +1100
committerMark Wright <gienah@gentoo.org>2016-12-02 12:07:09 +1100
commit9b2645061cdbc30b2a6bfaab0937083c91655070 (patch)
tree016a0cb1773225da8408208fd6101be76e3d8d7d /sci-mathematics/rstudio/files
parentdev-libs/leatherman: bup (diff)
downloadgentoo-9b2645061cdbc30b2a6bfaab0937083c91655070.tar.gz
gentoo-9b2645061cdbc30b2a6bfaab0937083c91655070.tar.bz2
gentoo-9b2645061cdbc30b2a6bfaab0937083c91655070.zip
sci-mathematics/rstudio: Bump to 1.0.44, thanks to David Luna for reporting.
Gentoo-Bug: 599282 Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.0.44-clang-pandoc.patch71
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.0.44-paths.patch130
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch21
3 files changed, 222 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.0.44-clang-pandoc.patch b/sci-mathematics/rstudio/files/rstudio-1.0.44-clang-pandoc.patch
new file mode 100644
index 000000000000..ed0fc8ebce4b
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.0.44-clang-pandoc.patch
@@ -0,0 +1,71 @@
+--- rstudio-1.0.44-orig/src/cpp/session/CMakeLists.txt 2016-10-19 08:32:41.000000000 +1100
++++ rstudio-1.0.44/src/cpp/session/CMakeLists.txt 2016-12-01 23:44:30.130725331 +1100
+@@ -25,24 +25,6 @@
+ if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-26")
+ message(FATAL_ERROR "Mathjax 2.6 not found (re-run install-dependencies script to install)")
+ endif()
+-if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc")
+- message(FATAL_ERROR "pandoc not found (re-run install-dependencies script to install)")
+-endif()
+-
+-# verify libclang is installed
+-if(WIN32)
+- set(LIBCLANG_VERSION "3.4")
+-else()
+- set(LIBCLANG_VERSION "3.5")
+-endif()
+-set(LIBCLANG_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/${LIBCLANG_VERSION}")
+-if(NOT EXISTS "${LIBCLANG_DIR}")
+- message(FATAL_ERROR "libclang ${LIBCLANG_VERSION} not found (re-run install-dependencies script to install)")
+-endif()
+-set(LIBCLANG_HEADERS_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers")
+-if(NOT EXISTS "${LIBCLANG_HEADERS_DIR}")
+- message(FATAL_ERROR "libclang builtin-headers not found (re-run install-dependencies script to install)")
+-endif()
+
+
+ # include files
+@@ -420,18 +402,6 @@
+ install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-26"
+ DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources")
+
+- # install pandoc
+- if(RSTUDIO_PACKAGE_BUILD_SLES)
+- # when producing a SUSE Linux Enterpise build, we want to install the
+- # static Pandoc binaries (see dependencies/common/install-pandoc)
+- set(PANDOC_EXTENSION_DIR "/static")
+- endif()
+- set(PANDOC_BIN "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc/1.17.2${PANDOC_EXTENSION_DIR}")
+- file(GLOB PANDOC_FILES "${PANDOC_BIN}/pandoc*")
+- install(FILES ${PANDOC_FILES}
+- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/pandoc)
+-
+ # install PDF.js
+ install(DIRECTORY "resources/pdfjs"
+ DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
+@@ -452,24 +422,6 @@
+ install(DIRECTORY "resources/pagedtable"
+ DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
+
+- # install libclang
+- if(WIN32)
+- file(GLOB LIBCLANG_32_FILES "${LIBCLANG_DIR}/x86/libclang.*")
+- install(PROGRAMS ${LIBCLANG_32_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86)
+- file(GLOB LIBCLANG_64_FILES "${LIBCLANG_DIR}/x86_64/libclang.*")
+- install(PROGRAMS ${LIBCLANG_64_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86_64)
+- else()
+- file(GLOB_RECURSE LIBCLANG_FILES "${LIBCLANG_DIR}/libclang.*")
+- install(PROGRAMS ${LIBCLANG_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang)
+- endif()
+-
+- # install libclang builtin-headers
+- install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers"
+- DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources/libclang")
+-
+ # install 64 bit binaries if we are on win64
+ if(WIN32)
+ if(NOT ("$ENV{PROGRAMW6432}" STREQUAL ""))
diff --git a/sci-mathematics/rstudio/files/rstudio-1.0.44-paths.patch b/sci-mathematics/rstudio/files/rstudio-1.0.44-paths.patch
new file mode 100644
index 000000000000..b2a1a33b44c2
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.0.44-paths.patch
@@ -0,0 +1,130 @@
+--- rstudio-1.0.44-orig/CMakeGlobals.txt 2016-10-19 08:32:41.000000000 +1100
++++ rstudio-1.0.44/CMakeGlobals.txt 2016-12-01 23:33:04.149326324 +1100
+@@ -123,7 +123,7 @@
+ else()
+ set(RSTUDIO_INSTALL_BIN bin)
+ endif()
+- set(RSTUDIO_INSTALL_SUPPORTING .)
++ set(RSTUDIO_INSTALL_SUPPORTING ${DISTRO_SHARE})
+ endif()
+
+ # if the install prefix is /usr/local then tweak as appropriate
+--- rstudio-1.0.44-orig/src/cpp/server/CMakeLists.txt 2016-10-19 08:32:41.000000000 +1100
++++ rstudio-1.0.44/src/cpp/server/CMakeLists.txt 2016-12-01 23:35:51.634862018 +1100
+@@ -155,7 +155,7 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}
+- DESTINATION ${RSERVER_INITD_DEBIAN_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_DEBIAN_DIR})
+
+ # install configured redhat init.d script
+ set(RSERVER_INITD_REDHAT_DIR "extras/init.d/redhat")
+@@ -163,7 +163,7 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}
+- DESTINATION ${RSERVER_INITD_REDHAT_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_REDHAT_DIR})
+
+ # install configured suse init.d script
+ set(RSERVER_INITD_SUSE_DIR "extras/init.d/suse")
+@@ -171,13 +171,13 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_SUSE_SCRIPT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT})
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT}
+- DESTINATION ${RSERVER_INITD_SUSE_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_SUSE_DIR})
+
+ # install pam profile
+ set(RSERVER_PAM_DIR "extras/pam")
+ set(RSERVER_PAM_PROFILE "${RSERVER_PAM_DIR}/rstudio")
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_PAM_PROFILE}
+- DESTINATION ${RSERVER_PAM_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_PAM_DIR})
+
+ # install configured apparmor profile
+ set(RSERVER_APPARMOR_DIR "extras/apparmor")
+@@ -185,9 +185,9 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_APPARMOR_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_APPARMOR_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_APPARMOR_PROFILE}
+- DESTINATION ${RSERVER_APPARMOR_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_APPARMOR_DIR})
+ install(PROGRAMS ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_APPARMOR_DIR}/apparmor-profile-load
+- DESTINATION ${RSERVER_APPARMOR_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_APPARMOR_DIR})
+
+ # install configured upstart profile
+ set(RSERVER_UPSTART_DIR "extras/upstart")
+@@ -195,12 +195,12 @@
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE}
+- DESTINATION ${RSERVER_UPSTART_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+ set(RSERVER_UPSTART_PROFILE_REDHAT "${RSERVER_UPSTART_DIR}/rstudio-server.redhat.conf")
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}
+- DESTINATION ${RSERVER_UPSTART_DIR})
++ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+
+ # install configured systemd profile
+ set(RSERVER_SYSTEMD_DIR "extras/systemd")
+--- rstudio-1.0.44-orig/src/cpp/server/ServerOptions.cpp 2016-10-19 08:32:41.000000000 +1100
++++ rstudio-1.0.44/src/cpp/server/ServerOptions.cpp 2016-12-01 23:33:04.151326331 +1100
+@@ -386,8 +386,8 @@
+
+ // convert relative paths by completing from the system installation
+ // path (this allows us to be relocatable)
+- resolvePath(resourcePath, &wwwLocalPath_);
+- resolvePath(resourcePath, &wwwSymbolMapsPath_);
++ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwLocalPath_);
++ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
+ resolvePath(binaryPath, &authPamHelperPath_);
+ resolvePath(binaryPath, &rsessionPath_);
+ resolvePath(binaryPath, &rldpathPath_);
+--- rstudio-1.0.44-orig/src/cpp/session/SessionOptions.cpp 2016-10-19 08:32:41.000000000 +1100
++++ rstudio-1.0.44/src/cpp/session/SessionOptions.cpp 2016-12-01 23:33:04.151326331 +1100
+@@ -49,7 +49,7 @@
+ namespace session {
+
+ namespace {
+-const char* const kDefaultPandocPath = "bin/pandoc";
++const char* const kDefaultPandocPath = "bin";
+ const char* const kDefaultPostbackPath = "bin/postback/rpostback";
+ const char* const kDefaultRsclangPath = "bin/rsclang";
+
+@@ -481,14 +481,14 @@
+ }
+
+ // convert relative paths by completing from the app resource path
+- resolvePath(resourcePath_, &rResourcesPath_);
+- resolvePath(resourcePath_, &agreementFilePath_);
+- resolvePath(resourcePath_, &wwwLocalPath_);
+- resolvePath(resourcePath_, &wwwSymbolMapsPath_);
+- resolvePath(resourcePath_, &coreRSourcePath_);
+- resolvePath(resourcePath_, &modulesRSourcePath_);
+- resolvePath(resourcePath_, &sessionLibraryPath_);
+- resolvePath(resourcePath_, &sessionPackageArchivesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &rResourcesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &agreementFilePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwLocalPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &coreRSourcePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &modulesRSourcePath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionLibraryPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionPackageArchivesPath_);
+ resolvePostbackPath(resourcePath_, &rpostbackPath_);
+ #ifdef _WIN32
+ resolvePath(resourcePath_, &consoleIoPath_);
+@@ -498,7 +498,7 @@
+ resolvePath(resourcePath_, &sumatraPath_);
+ resolvePath(resourcePath_, &winutilsPath_);
+ #endif
+- resolvePath(resourcePath_, &hunspellDictionariesPath_);
++ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &hunspellDictionariesPath_);
+ resolvePath(resourcePath_, &mathjaxPath_);
+ resolvePath(resourcePath_, &libclangHeadersPath_);
+ resolvePandocPath(resourcePath_, &pandocPath_);
diff --git a/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch b/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
new file mode 100644
index 000000000000..7eafd4386abd
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
@@ -0,0 +1,21 @@
+--- rstudio-1.0.44-orig/src/cpp/server/CMakeLists.txt 2016-10-19 08:32:41.000000000 +1100
++++ rstudio-1.0.44/src/cpp/server/CMakeLists.txt 2016-12-02 11:11:45.259050839 +1100
+@@ -203,17 +203,12 @@
+ DESTINATION ${RSERVER_UPSTART_DIR})
+
+ # install configured systemd profile
+- set(RSERVER_SYSTEMD_DIR "extras/systemd")
++ set(RSERVER_SYSTEMD_DIR "lib/systemd/system")
+ set(RSERVER_SYSTEMD_PROFILE "${RSERVER_SYSTEMD_DIR}/rstudio-server.service")
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_SYSTEMD_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE}
+ DESTINATION ${RSERVER_SYSTEMD_DIR})
+- set(RSERVER_SYSTEMD_PROFILE_REDHAT "${RSERVER_SYSTEMD_DIR}/rstudio-server.redhat.service")
+- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_SYSTEMD_PROFILE_REDHAT}.in
+- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE_REDHAT})
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE_REDHAT}
+- DESTINATION ${RSERVER_SYSTEMD_DIR})
+
+ elseif(APPLE)
+