summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-06-26 18:57:33 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-06-26 18:57:33 +0700
commitbc79aa41cb7575acc5b3da468d1eba02cf4d921c (patch)
tree6729c465c4feb978333e6552ef5ec41b76b41417 /sci-mathematics
parentsys-apps/hwids: bump to v20180518 (diff)
downloadgentoo-bc79aa41cb7575acc5b3da468d1eba02cf4d921c.tar.gz
gentoo-bc79aa41cb7575acc5b3da468d1eba02cf4d921c.tar.bz2
gentoo-bc79aa41cb7575acc5b3da468d1eba02cf4d921c.zip
sci-mathematics/ginac: bump to 1.7.4
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/ginac-1.7.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index 6e6127ecfc47..375c838a4ebe 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1,2 +1,3 @@
DIST ginac-1.6.6.tar.bz2 1028211 BLAKE2B 3f939e82cfa833ee5ba6714d4db38edf80de4e380b0bcacfe23992ca3c5eefbd719506cf77f57aebc1517968eff7d26c8d24d14167c596e5e7145458367074e8 SHA512 495ef255dd32e71ee91257a515c0566e56525e0c54c8955c19beaf9e2e55457f7d8171c7e5f6e4f29f555f5d262bbaf4edf4f033166c4904c016987a5029e958
DIST ginac-1.7.2.tar.bz2 1056339 BLAKE2B 116be56df781d6e9675f914b9f75af86736183dbd26a1ff5e7f6f3cc79e4efc31449bc4fd5454b0f73cf189749a00f071d2b7cc519005e1f3b772b6b1521d508 SHA512 5c356beb8e0830b9f5805870f67298d4c19e512db8b8f46a37b490c19179a5c99e4497439e5adb575dd97e7deb5fe0b931a4b6db80e98a8e1e6f46977e33d8cf
+DIST ginac-1.7.4.tar.bz2 1062724 BLAKE2B 742ec49629fecb14a2294ca9e8dc1df52cdad2d2e11cebbffa3c23a64592c597f872dd8294bc9324ea1f88e540f75015d09ea526ef9d67689943bb6c94325911 SHA512 740c221a0115bd233723f3032a77b1389122694b2893c52d4c7ed778c7332981c152f6ea81b35352882c14b42542f64963d5199af3f492af97f79a6e6c52156c
diff --git a/sci-mathematics/ginac/ginac-1.7.4.ebuild b/sci-mathematics/ginac/ginac-1.7.4.ebuild
new file mode 100644
index 000000000000..d1ccecc918ff
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.7.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="https://www.ginac.de/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ append-cxxflags -std=c++14
+ econf --disable-rpath
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ pushd doc/reference >> /dev/null || die "pushd doc/reference failed"
+ emake html pdf
+ popd >> /dev/null
+ pushd doc/tutorial >> /dev/null || die "pushd doc/tutorial failed"
+ emake ginac.pdf ginac.html
+ popd >> /dev/null
+ fi
+}
+
+src_test() {
+ pushd ../${P}_build > /dev/null
+ emake check
+ popd > /dev/null
+}
+
+src_install() {
+ default
+ if use doc; then
+ pushd doc > /dev/null || die "pushd doc failed"
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ newins reference/reference.pdf reference.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/doc/examples/*.cpp examples/ginac-examples.*
+ popd > /dev/null
+ fi
+}