summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-11 23:35:58 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-11 23:35:58 +0100
commitcc8deae86628989356bdaa48405abe7a867cb49c (patch)
tree4836cb4015b77f7834bc541ce977127ac48462b6 /sci-mathematics
parentnet-fs/smbtad: Drop debug use flag (diff)
downloadgentoo-cc8deae86628989356bdaa48405abe7a867cb49c.tar.gz
gentoo-cc8deae86628989356bdaa48405abe7a867cb49c.tar.bz2
gentoo-cc8deae86628989356bdaa48405abe7a867cb49c.zip
sci-mathematics/diagrtb: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
index 1283039df7eb..27c9262aa64e 100644
--- a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils fortran-2
@@ -20,11 +20,14 @@ S="${WORKDIR}"/Source_RTB2011
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use examples EXAMPLES)
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
)
+
cmake-utils_src_configure
}